 Добро пожаловать

Добро пожаловать

обновлено 14.04.2007 12:43

Дорогие пользователи!

Вашему вниманию предлагается переработанный вариант программы для работы в пиринговых сетях FlylinkDC++

FlylinkDC++ базируется на исходном коде ApexDC++ 0.4.0

оптимизирована для работы в ADSL и LAN сетях .

Скачать последнюю версию программы (256)

Скачать файл справки (от 14 апреля 2007)

В этой программе мы попытались сделать все то, что составит комфорт и спокойствие обыкновенному пользователю. Добавлено много различных полезностей.

Основные возможности:

· Увеличена скорость закачки распространенных файлов
· Автоподключение уже к добавленным хабам при первом запуске.
· IP фильтрация (подробнее)
· Автоматически сохраняет настройки (в случае падения всегда можно будет восстановится)
· Программа автоматически определяет запуск под эмулятором wine(linux) и динамически корректирует свои настройки для исключения "креша"
· При просмотре файл-листа и обнаружении уже имеющегося у Вас файла, будет показано где он хранится
· Программа постоянно развивается и совершенствуется (посмотреть лог изменений)
· Улучшено быстродействие, особенно отразится на слабых машинах
· Имеющиеся у вас файлы подкрашиваются другим цветом
· Возможность выбора любых ограничений скорости (скорость входящего не зависит от исходящего потока)
· Используется система "Автобан" для запрета скачивания файлов пользователями, не попадающих под заданные критерии
· Новая группа поиска "CD/DVD Image"
· Упрощение процедуры поиска личного IP адреса (возможность вручную указывать скрипт определения)
· Добавлен вывод логотипа и название района
· Расширена информация о пользователях
· Можно прикинуться другим клиентом (для тех, кому запрещают использовать FlylinkDC++)
· Новый язык - "Албанский"
· Можно добавить свой город и свои избранные хабы в будущую сборку клиента

Посмотреть изменения

Видео по настройке программы и модема

Huawai SmartAX MT880

D-Link 500T (без прошивки)

ZyXEL Prestige 660R

Программа не так сложна в обращении как кажется, в данный момент, пока вы читаете, этот хелп продолжает совершенствоваться, так же вам доступен форум на котором вы сможете что-то узнать. Там уже рассмотрено много случаев - и может быть вы найдете ответ на свой вопрос.

Форум FlylinkDC++ | Все вопросы относительно информации на сайте E-mail - M.S.A
Общий форум о DC++ всех версий | Сборка программы - PPA (ICQ 46403100) - Drakon (ICQ 204686546)
Online справка | Документация по настройке модемов - Бэрик (ICQ 204000748)
Скачать файл справки (от 14 апреля 2007) Скачать последнюю версию программы (256) | Видео подготовили: M.S.A, Squork, SkazochNik Графику рисует KS!ON - E-mail


Быстрый старт!

Как быстро начать использование FlylinkDC++

Если ты только установил...то тебе надо выполнить всего несколько шагов, что бы стать полноценным жителем пиринговой сети. Итак начнем:

Шаг 1.

В появившемся перед тобой окошке вписываешь свой Ник, Е-Mail и Описание

Шаг 2.

Переходишь в настройку "Шара". Шарим, расставляя галочки, те ресурсы которые хотим предложить для доступа другим участникам сети

Шаг 3.

Закрываем окно настроек, нажатием кнопки "ОК"


FAQ

Ответы на часто задаваемые вопросы:

Как настроить модем (портфорвардинг)

читам здесь

У меня уже стоит Apex или Strong DC. Могу ли я перейти на FlylinkDC бес потери настроек?

Да. Установите FlylinkDC или попросите у кого-либо FlylinkDC.exe + файл русификации и скопируйте в папку со своим клиентом. Запускайте FlylinkDC.exe и наслаждайтесь.

Не могу подключиться к хабу!

Возможно на данном хабе стоит какое-то ограничение: объем шары, количество слотов.

[02:13:46] *** Соединён

[02:13:46] <VerliHub> This Hub is running version 0.9.8c (Tue Mar 8 11:00:00 CET 2005) of VerliHub (RunTime:2weeks 2days ).

[02:13:46] <VerliHub> This hub is enhanced by plugman for Verlihub.

[02:13:46] <VerliHub> You share 3MB, but the min share is 5000MB. (Active:5000MB / passive 5000)

[02:13:46] *** Получено перенаправление на хаб, с которым вы уже соединены

[02:13:46] *** Отключен

А если он просто отключен и включиться только вечером?!

Проверьте настройки соединения

Какие бывают режимы в DC? Чем они отличаються?!

читать здесь

Как узнать, правильно я настроил порты или нет?!

2) Запускаешь сервис (программу, сервер) для данного открытого порта

3) Настраиваешь фаервол (если есть)

4) Переходишь по ссылке: http://freelan.leschat.net/test.php

5) Забиваешь номер тестируемого порта и нажимаешь Enter.

Тест работает только для TCP протокола

Не работает поиск, что делать?

Проверьте правильность настроек подключения
Если вы работаете в пассивном режиме то поставьте галочку "использовать пассивный поиск"
Если в активном режиме - обязательно снимите ее

Проверьте, прокинули ли вы порт UDP или нет?!

читать здесь

Как добавить хаб?

Открываете окно "Избранные хабы"
Нажимаете на кнопку "Новый" => вылетит окошко, но нам нужны только три секции (ниже скрин)
заполняете Название, Адрес, Описание (опционально)
нажимаете "Ок"

Все хаб добавлен!

Скорость скачивания в DC++ ?

В DC скорость скачивания предугадать невозможно. Она варьируется в пределах от совсем маленькой ( < 1kb/s) до максимально возможной ( > 1 Mb/s)

Я делал по инструкции, у меня не получилось!

Это исключено, не вы один делали по ней - те кто делали у них получалось. Возможно вы на каком-то шаге допустили ошибку, перепроверьтесь.

Магнет-ссылки - что это?

читаем здесь

А это бесплатно?

Ответ ДА! до 2007 года согласно тарифным планам, все внутри областные ресурсы, кои являются все ссылки данные тут и сама прога FlylinkDC++ - так что пользуйтесь, не тратьте время зря)

Как искать файлы?

Когда вы не знаете, где или у кого лежит нужный вам файл, имеет смысл воспользоваться поиском. Окно поиска открывается при нажатии на пиктограмму "Лупа" вверху окна, или если выбрать в меню пункт Вид->Поиск. Тут также всё просто - вводите в поле "Искать" ключевое слово, которое должно содержаться в имени файла и нажимаете кнопку поиск, после этого в правой части окна выводится список найденных файлов. Файлы появляются по мере нахождения, и полный процесс поиска может занять порядка минуты. После успешного нахождения файла его также можно скачать двойным щелчком мыши, или нажать правой кнопкой мыши и в контекстном меню выбрать другую функцию, например, можно просмотреть все файлы у пользователя, чей файл был найден и т.д.

Дополнительно

Что обозначают значки рядом с никами?

В основном - тип подключения. Например иконка сетевого диска - cable, домик (человек) - lan. Огненная стена - обозначает что клиент работает в пассивном режиме. Булава - что с этого клиента много скачивают. Серая иконка означает что пользователь в режиме away (отошел), иконка с зеленой галочкой - с этим пользователем уже было соеденение.

Как отправить сообщение пользователю?

Щелкните правой кнопкой по пользователю в списке, выберите Send private message (отправить частное сообщение)

Не скачивается ничего - пишет Соединяюсь... и всё!!!

тут несколько вариантов

1) Просто подожди минуты 2-3. Возможно у того пользователся превышено число одновременных коннектов (слотов) и вы встали к нему в очередь на соединение. Если не сработает и не откроется окно со списком файлов, попробуй запросить файл-лист еще с кого-нибудь. Если не получается вообще ни с кого, значит проблемы со связью:

2) Проверь файрвол! Проще всего ему разрешить выполнять любые действия для DC++, если заработает тогда уже разбираться с его настройками (если нужно). Если файрвола нет, нужно иметь ввиду что в windows XP есть встроенный "брэндмауэр". Его нужно отключить или настроить. Он находится в Панели управления-Брандмауер. Нужно внести DC в исключения.

Файл-лист показывает. Как теперь качать?

Навести на файл или папку мышкой, нажать правую кнопку, в меню выбрать "закачка". После этого файл добавится в очередь загрузки. Это не значит что он тут же начнет качаться! Это произойдет тогда, когда у того пользователя освободятся слоты. Если этот файл есть еще у кого-то в нашей сети, то о будет качаться сразу из нескольких источников! А может вообще скачаться совсем не с того пользователя, с которого вы его поставили качать! Но это будет именно тот файл, который вам нужен.

А как DC++ узнает что два файла одинаковые? По имени? Размеру?

нет, по контрольной сумме TTH. Для каждого файла считается такая контрольная сумма. И если она одинакова для двух файлов одного размера - значит они абсолютно одинаковые. Даже если у них разные имена! (при скачке имя файла будет таким, с каким вы его заказали качаться). Именно поэтому DC++ тормозит при расшаривании папок и долго думает. Она считает контрольные суммы для всех файлов!

Что такое ТТН? Хеширование? Почему оно у меня делается и всё тормозит?

TTH - в двух словах, уникальное имя файла, не зависящая от того, как его назвали вы. То есть, если 2 файла одинаковы, то независимо от их обычных названий, ТТН у них будет одинаков. Но даже если названия и даже размер одинаковы, но ТТН разный, то это РАЗНЫЕ файлы.(и один из них скорее всего битый).

Хеширование(hashing) - это получение "уникального имени" путём анализа файла. Это требует ресурсов компа, так что при первом запуске ДС++ и хешировании ваших файлов, копм будет тормозить.

Где искать скачанные файлы?

читаем здесь

А другие смогут мне заливать в общие папки что-то... или стирать?!

нет конечно. Папки выданы только для чтения (скачивания)

Что такое слоты? сколько ставить?

читаем здесь

Цвет пользователей в списке передач

читаем здесь

Программа начинает качать очень много файл-листов. Что это?

читаем здесь

При добавлении закачки через магнэт-ссылки, название становиться непонятным. Почему?

Это баг браузера Internet Explorer

Что такое DC?

Direct Connect это peer-to-peer файлообменная система, построена по тому же принципу что и, например, eDonkey, Kazaa, Napster и тп. На компьютер ставится специальная программа - DC клиент, в котором указывается какие папки сделать общими, после чего он подключается к общему серверу , и через сервер позволяет увидеть другие компьютеры подключенные к нему.


"Горячие" клавиши

F1 - Открыть справку

Alt - Подсветить главное меню, что бы было видно указатели перемещения.Делает статус-бар невидимым. Статус-бар станет видимым после повторного нажатия Alt или при открытии нового окна. Возможность Windows

Tab - Закончить написание Ника. Находит автоматически в юзер-листе

Ctrl + 1 - Включить/отключить панель управления

Ctrl + 2 - Включить/отключить строку состояния

Ctrl + 3 - Включить/отключить окно передач

Ctrl + 4 - Включить/отключить панель Winamp

Ctrl + D - Очередь скачивания

Ctrl + E - Обновить список файлов

Ctrl + F - Избранные хабы

Ctrl + N - Открыть блокнот

Ctrl + L - Открыть файл-лист

Ctrl + Q - Быстрое подключение

Ctrl + R - Переподключение

Ctrl + S - Открыть поиск

Ctrl + T - Перенаправление

Ctrl + U - Друзья

Ctrl + C - Скопировать текст. Возможность Windows

Ctrl + V - Вставить текст. Возможность Windows

Ctrl + X - Вырезать. Возможность Windows

Ctrl + Y - Поторить редактирование текста. Возможность Windows

Ctrl + Z - Отменить редактирование текста. Возможность Windows

Ctrl and + (on the numeric keyboard) - Если в активном окне, такие как: юзер-лист, окно передач, поиск, нажать Ctrl and + (on the numeric keyboard) то все колонки автоматически примут размер, необходимый для полного отображения текста

Ctrl + Tab - Переключение между окнами. Возможность Windows

Alt + C - В Избранных хабах: подключиться к хабу

Alt + U - В ADL-поиске и Избранных хабах: переместить элемент вверх

Alt + D - В ADL-поиске и Избранных хабах: переместить элемент вниз

Alt + N - В ADL-поиске и Избранных хабах: добавить новый элемент

Alt + P - В ADL-поиске и Избранных хабах: редактировать элемент

Alt + R - В ADL-поиске и Избранных хабах: удалить элемент

Alt + S - Отправить сообщение в чат

+ (on the numeric keyboard) - В Очереди скачивания: повысить приоритет

- (on the numeric keyboard) - В Очереди скачивания: понизить приоритет


Портфорвардинг

Задается очень много вопросов по поводу правильной настройки программы FlylinkDC++. Постараюсь внести ясность.
Для правильной работы программы необходимо настроить и модем, и саму программу (а возможно и операционную систему). Как? Этим и займемся...
Для начала определимся со своим внутренним локальным сетевым адресом.

Жмем два раза мышкой на указанный значок. И наблюдаем следующую картинку. Если вдруг у вас такого значка нет делаем так: Пуск - Настройка - Панель управления - Сетевые подключения - Подключение по локальной сети - результат будет тот же.
Жмем кнопочку Свойства

Жмем Протокол интернета (TCP/IP)

Видим следующее:

Вот это и есть ваш внутренний локальный сетевой адрес. На него то мы и будем перенаправлять данные с модема.
Теперь настроим модем. В нем нужно открыть входящие порты, и перенаправить эти порты на ваш компьютер (на внутренний локальный сетевой адрес).
Рассмотрим самые распространенные модели.

1. ZyXEL Prestige 660R
2. D-Link DSL-500T (без перепрошивки)
3. D-Link DSL-500T (c перепрошивкой)
4. HUAWEI SmartAX-MT880

5. ASUS AAM6010EV


ZyXEL Prestige 660R

1. Настройка ZyXEL Prestige 660R

Набираем в браузере 192.168.1.1 (или тот адрес, что вы присвоили модему) и попадаем в интерфейс модема:

Вводим свой пароль и попадаем в следующее окошко:

Жмем ссылочку NAT и видим другое окно:

Выбираем SUA Only и жмем Edit Details . Откроется следующее окно:

Если вы настраиваете модем впервые, то в этом окне вы увидите сплошные нули. Открываем порты и перенаправляем их на внутренний локальный сетевой адрес, то есть просто заполняем табличку данными, как показано на рисунке. В первой строчке оставляем 0.0.0.0 - тем самым, открывая не все, а только нужные нам порты: 30001и 30002. Не забываем нажать SAVE для сохранения сделанных настроек.

После этого жмем на пункт меню Main Menu и, выходим в главное меню:

Нажимаем System Status, и видим следующее:

Выделенная строка, это ваш внешний сетевой адрес, присвоенный вам провайдером. Он понадобится для настройки программы FlylinkDC++. На этом настройка модема закончена.

Переходим к настройке самой программы FlylinkDC++


D-Link DSL-500T (без перепрошивки)

2. Настройка D-Link DSL-500T (без перепрошивки)
Набираем в браузере 192.168.1.1 (или тот адрес, что вы присвоили модему) и попадаем в интерфейс модема:

Вводим свой пароль и попадаем в следующее окошко:

Идем в закладку Status, жмем Connection Status. Видим:

Выделенная строка, это ваш внешний сетевой адрес, присвоенный вам провайдером. Он понадобится для настройки программы FlylinkDC++. Жмем на закладку Advanced , нажимаем кнопку Lan Clients, и попадаем в следующее окно:

В поле IP Address вбиваем адрес своего внутреннего локального сетевого интерфейса и жмем кнопку Add. Должно получиться следующее:

Жмем Apply. Нажимаем кнопочку Port Forwarding. Открывается окно:

Жмем User и View. Видим

Нажимаем Add и создаем новое правило – то есть, открываем порты

Вбиваем значения и жмем Apply. После нажатия видим такое окно (подчеркнуто красным):

Далее вбиваем следующие значения (подчеркнуто синим) и жмем Apply. При этом не забываем правильно выбирать значение Protocol – оно меняется для разных портов

При этом не забываем правильно выбирать значение Protocol – оно меняется для разных портов.

Далее жмем кнопку Port Forwarding, ставим галочку на User, выбираем созданное правило (DC) и жмем Add. В итоге должно получиться следующее:

Жмем Apply. Жмем на вкладку Tools, затем System Commands

И жмем Restart. Все, модем настроен…

Переходим к настройке самой программы FlylinkDC++


D-Link DSL-500T (c перепрошивкой)

3. Настройка D-Link DSL-500T (с перепрошивкой)
Набираем в браузере 192.168.1.1 (или тот адрес, что вы присвоили модему) и попадаем в интерфейс модема:

Вводим свой пароль и попадаем в следующее окошко:

Идем в закладку Status, жмем Connection Status. Видим:

Выделенная строка, это ваш внешний сетевой адрес, присвоенный вам провайдером. Он понадобится для настройки программы FlylinkDC++. Жмем на закладку Advanced , нажимаем кнопку Lan Clients, и попадаем в следующее окно:

В поле IP Address вбиваем адрес своего внутреннего локального сетевого интерфейса и жмем кнопку Add. Должно получиться следующее:

Жмем Apply. Нажимаем кнопочку Virtual Server. Открывается окно:

Жмем User и View. Видим

Нажимаем Add и создаем новое правило – то есть, открываем порты:

Вбиваем значения и жмем Apply. После нажатия видим такое окно (подчеркнуто красным):

Затем вбиваем следующие значения (подчеркнуто синим) и жмем Aplly.

При этом не забываем правильно выбирать значение Protocol – оно меняется для разных портов.

Далее жмем кнопку Virtual Server, ставим галочку на User, выбираем созданное правило (DC) и жмем Add. В итоге должно получиться следующее:

Жмем Apply. Жмем на вкладку Tools, затем System

И жмем Save and Reboot. Все, модем настроен…

Переходим к настройке самой программы FlylinkDC++


HUAWEI SmartAX-MT880

4. Настройка HUAWEI SmartAX-MT880

Набираем в браузере 192.168.1.1 (или тот адрес, что вы присвоили модему) и попадаем в интерфейс модема:

Вводим свой пароль и попадаем в следующее окошко:

Выделенная строка, это ваш внешний сетевой адрес, присвоенный вам провайдером. Он понадобится для настройки программы FlylinkDC++. Далее жмем Other Setting, затем NAT и попадаем сюда:

Ставим «галочку» PVC-0 NAT Enable, жмем кнопку Port Mapping Set, и видим такое окно:

Если вы настраиваете модем впервые, то в этом окне вы увидите сплошные нули. Открываем порты и перенаправляем их на внутренний локальный сетевой адрес, то есть просто заполняем табличку данными, как показано на рисунке. В первой строчке оставляем 0.0.0.0 - тем самым, открывая не все, а только нужные нам порты: 30001и 30002. Не забываем нажать SAVE для сохранения сделанных настроек.

Жмем на ссылку Restart, выставляем опцию Current Setting и жмем кнопку Restart

Все, модем настроен…

Переходим к настройке самой программы FlylinkDC++


ASUS AAM6010EV

5. Настройка ASUS AAM6010EV

Набираем в браузере 192.168.1.1 (или тот адрес, что вы присвоили модему) и попадаем в интерфейс модема:

Вводим свой пароль и попадаем в следующее окошко:

Идем в закладку Status, жмем Connection Status. Видим:

Выделенная строка, это ваш внешний сетевой адрес, присвоенный вам провайдером. Он понадобится для настройки программы FlylinkDC++. Жмем на закладку Advanced , нажимаем кнопку Lan Clients, и попадаем в следующее окно:

В поле Enter IP Address вбиваем адрес своего внутреннего локального сетевого интерфейса и жмем кнопку Apply. Должно получиться следующее:

Жмем Apply. Нажимаем кнопочку Port Forwarding.

Жмем User (табличка Category) Открывается окно:

Нажимаем New и создаем новое правило – то есть, открываем порты:

Вбиваем значения и жмем Apply. После нажатия видим такое окно (подчеркнуто красным):

Затем вбиваем следующие значения (подчеркнуто синим) и жмем Aplly.

В итоге должно получиться вот такое правило. При этом не забываем правильно выбирать значение Protocol – оно меняется для разных портов.

Далее жмем кнопку Port Forwarding, ставим галочку на User, выбираем созданное правило (DC) и жмем Add. В итоге должно получиться следующее:

Жмем Apply. Жмем на вкладку Tools, затем System Commands.

И жмем Save All, затем Restart. Все, модем настроен…

Переходим к настройке самой программы FlylinkDC++


Настройки программы

Рассмотрены наиболее нужные опции программы


Общие

"Персональная информация"

Ник * - ваше отображаемое для других пользователей имя

E-Mail - ваша электронная почта

Описание - для того, чтобы другим пользователям было понятно, какие ресурсы у вас расшарены, введите небольшое пояснение

"Ширина канала" *

Здесь указывается скорость исходящего потока. Этот параметр ни на что не влияет - так как она почти у всех одинаковая - 1 Mb/s, у некоторых пользователей 2 Mb/s. Так что в этом параметре можно смело ставить понравившееся вам значение.

"Описание"

Дополнительные сведения о вашем клиенте.

Показать скорость - при выставлении этой опции, вам будет доступен пункт От/До где можно поставить предел, в котором варьируется скорость отдачи вашего канала.

Показать ограничение - если вы это отметили, то пользователи будут знать что у вас стоит ограничение на отдачу.

Показать слоты - в графе описание будет показываться количество открытых вами слотов.

при таких настройках, другие пользователи будут видеть следующее

* отмечены обязательные пункты


Настройка соединения

"Присвоенный адрес"

Тут вписывается ip адрес вашей сетевой карты. Выбираем из раскрывающегося списка нужный (если у вас их много)

"Настройки ВХОДЯЩИХ соединений"

По умолчанию стоит Брандмауэр, и это действительно "худший вариант", т.к вы не сможете скачивать файлы у пользователей с таким же режимом. Если не знаете как настраивать "Брандмауэр с ручным перенаправлением портов", то на данном этапе оставьте как есть.

Пункты Прямое соединение и Брандмауэр с UPnP ставить не нужно!

Если по кнопка "Найти IP адреса" у Вас не работает, посмотрите данные в модеме (где найти, читайте для вашего модема раздел Портфорвардинг)

Обновить IP при старте - отметьте, если у вас динамический IP , при каждом запуске программа будет выставлять его автоматически.
Примечание: обязательно проверьте, что бы адрес определения ip был верным

"Настройки ИСХОДЯЩИХ соединений"

Здесь указывается способ исходящего подключения.


Скачивание

"Папки"

Папка для скачивания по умолчанию - место, куда будет автоматически сохраняться файл

Папка для временных файлов - место, где хранятся еще недокаченные файлы

Примечание: будте внимательнее при выборе мест сохранения скаченных/временных файлов - у вас должно быть достаточно места на HDD. Для скачивания файлов размером больше чем 4GB требуется раздел, где находятся папки для временных/скаченных файлов, NTFS

"Ограничение скорости"

Максимум одновременно получаемых файлов - Определяет максимальное возможное количество одновременно получаемых файлов

Максимум одновременных скачиваний - определяет максимально возможное количество потоков скачивания (на один файл может быть множество потоков)

При превышении выдает сообщение:

Под вкладки

Здесь можно ввести для удобства список тех папок в которые вы будете скачивать, выглядит это так:

"Сегментированное скачивание"

Включить сегментирование - включает или выключает деление файла на сегменты (по умолчанию включено)

Поиск альтернативных TTH источников - время через которое программа будет искать дополнительные источники скачивания файла (от 2 минут до бесконечности)

Жестко устанавливать число сегментов - количество сегментов, то есть частей, на файл. желательно ставить в пределах от 40 до 70

"Приоритет по имени файла"

Файлы с тем или иным расширением будут автоматически принимать высший или низший приоритет, в зависимости от того как вы настроете.

"Остальные настройки"

Автоматическое добавление в очередь для совпадений из авто-поиска - В этом режиме программа скачивает файл-лист каждого альтернативного источника и ищет в нем альтернативы на остальные закачки.

Например, Вы качаете какой-нибудь альбом, в котором 15 песен. С выключенной опцией надо искать альтернативы для всех 15 файлов. С включенной опцией достаточно найти альтернативы для одного файла, потом программа скачает файл-листы со всех, у кого найдена эта песня и будет искать в файл-листе остальные.

Примечание: Не удивляйтесь, если программа самопроизвольно начинает скачивать много файл-листов.

Пропускать файлы нулевого размера - не учитывать файлы размером 0 байт

Не скачивать файлы, уже находящиеся в шаре - если не хотите закачивать одни и теже файлы несколько раз, то оставьте как есть

Использовать антифрагментационный метод скачивания - включает резервирование на винчестере места для скачиваемого файла в размере этого самого файла, соответственно, уменьшается объем свободного места. Можно включить, если свободного места на диске много.

Включить обновление очереди в ральном времени - Если отключено. В этом случае будут реже обновляться "полоски", показывающие прогресс скачки/отдачи файлов. (рекомендуеться для слабых машин)


Шара

"Расшареные папки"

Выбираете те папки, которые хотите предоставить для скачивания. На многих хабах стоит минимальное ограничение на размер шары, так что рекомендуется расшарить не менее чем 15-20 GB

Слоты отдачи - количество подключений к вам. На некоторых хабах также стоит ограничение на количество слотов, так что рекомендуется ставить 10

Отношение хабы/слоты - в зависимости от количества одновременно подключенных хабов автоматически устанавливается кол. слотов (в любом случае будет не меньше вами установленного) по формуле слоты=x*хабы, где х какое то число (в данном случае 3)

Открыть доп. слот, если скорость ниже... - если у вас заняты все свободные слоты, но скорость ниже установленной здесь (в этом пункте), то автоматически открывается еще один слот

Мини-слот - слои для мини-файла

Мини-файл - размер мини-файла

Мини-файл - это файл размер которого меньше х, где х установленное ваши число (по умолчанию 10 MB)

Экстра-слот тем, у кого сейчас качаю - предоставляет возможность скачивать у вас данные тем, у кого вы качаете, в независимости от того, есть у вас свободные слоты или нет


Внешний вид

здесь описаны не будут, так как там и так все интуитивно понятно

p.s: может быть в следующей версии файла справки

Дополнено:

увеличить строку ввода сообщения в два раза


Дополнительно

Рассмотрим некоторые параметры этой вкладки:

Авто-ушел при сворачивании - устанавливает ваш статус в положение "Ушел" при сворачивании программы. В обратном направлении тоже работает (хотя у меня не всегда)

Автоматически следовать перенаправлениям

Очищать стоку поиска - автоматически стирает ваш запрос перед следующим поиском

Сворачивать при запуске программы - при старте прячется в трее

Делать аварийную копию настроек при запуске - если вдруг случится "креш", то у вас найдется копия настроек для отката к ним

Использовать расширения для Скачивания в поиске

Не показывать запрещенные файлы

Перехватывать ссылки вида dchub:// этим DC клиентом - сообщает системе какой программой открывать магнет-ссылки

Установить обработчик магнет-ссылки при запуске - при первом обнаружении магнет-ссылки программа спрашивает, что нужно делать в последующее время

Не удалять списки файлов при выходе - сообщает программе, что ей не нужно при выходе удалять списки файлов, просмотренных пользователей

Автоматически отключать юзера, покинувшего хаб - иногда бывает, что пользователь, отключившийся от хаба, продолжает смачивать у вас файлы. При установке этого пункта, он (юзер) будет отключаться.

Не отключать автоматически друга, покинувшего хаб - если работает параметр выше, то ваши "друзья" тоже будут отключаться. Этот параметр не дает этого делать.

Не посылать сообщение "ушел" ботам - при поступлении ЛС в статусе "ушел" - программа отсылает сообщение (как бы автоответчик). Если включено. то ботам оно не будет посылаться

Закончить на первом совпадении авто-поиска

Разрешить безопасные и сжатые передачи

Принимать команды юзера от хаба

Всегда использовать пассивный режим для поиска - если вы не настроили портфорвардинг, то галка должна стоять

Посылать неизвестные команды хабу

Добавлять скаченные файлы в шару - автоматически расшариваются скаченные фалы

Использовать CTRL для строк истории

Команды отладки

Посылать "мусор" на входящее подключения

Посылать "мусор" на исходящее подключения

Включить веб-сервер - включает Web-Server для удаленного надблюдения за состоянием FlylinkDC++

Включить обнаружение конфликтующих программ - DC будет предупреждать вас о том, что какие-то другие проги конфликтуют с ней

Не напоминать о новых версия FlylinkDC++ (version.xml все равно скачивается) - не уведомлять о нахождении новой версии

Скрывать темы топика - не отображать тему канала

Активировать фильтр поиска/списка юзеров по нажатии Enter - Для списка пользователей хаба, фильтр активируется нажатием Enter'а

Показывать меню оболочки после передачи

Сохранять положении окна настроек - запоминает в каком месте последний раз было окно настроек

Включить поддержку $HubTopic support

Стартовать хабы свернутыми - открывать хабы свернутыми

Открывать логи внутри программы (влияет на быстродействие, если логи очень большие) - последняя переписка открывается в FlylinkDC++

Использовать внешнюю программу для быстрого просмотра текстов

"Скопировать магнет-ссылку как веб-ссылку"

Эта форма позволяет копировать магнет-ссылки уже в готовом виде для форумов, веб-страниц и др.

Рассмотрим на примере моей строки:

<!--hide="" userlevel=1--><a href="%[magnet]" title="%[name]"><strong>Скачать из DC++ | %[size] Mb</strong></a><!--/hide-->

при вставке на страницу получится: скрытый текст, ссылка вида Скачать из DC++ | <n> Mb, + пояснение ссылки (будет выводится название файла)

"Какой у вас магнитафон?"

Так называемый "спам" от проигрывателя, показывает что у вас играет в данный момент при нажатии на кнопочку (читаем тут)

Формат выводимой строки, при отправки команды /winamp

все довольно просто, выбираем из списка плеер, в строке пишем что угодно: +me <ваш текст> <параметр>

Примечание: чередовать можно как угодно и сколь угодно раз ( +me обязательно должно стоять первым)

при нажатии на [image] покажется дополнительные параметры строки

Для экспертов (если не знаете, то на первых порах лучше ничего не менять)

"WebServer"

Система контроля хода работы приложения удаленно. Позволяет отслеживать действия клиента, находясь за другим компьютером.

По умолчанию отключен

Порт - любой не занятый. Номер порта через который будет идти передача данных

Юзер - логин для входа в систему. Устанавливаете и знаете только Вы, или тот кому вы сказали.

Пароль - как и логин, используется для входа в систему.

"Действие"

Эта часть опций относится к режиму простоя DC, то есть когда вы ничего не скачиваете. Вы можете поставить на закачку кучу файлов и уйти, по завершению задания, DC может выполнить одно из действий. Для активации нажмите на кнопку.

По умолчанию отключен

Выберите из списка одно из перечисленных действий и установите время для обратного отсчета.

Логи

отметте галочкой те параметры, которые вы хотите, чтобы программа вела записи

Команды пользователя

Если вы часто набираете какой-то текст или цепочку связанных команд, то создайте для облегчения одну команду, которая будет объединять в себе все то что вам нужно!

Ограничение скорости

"Ограничение скорости"

Включает или отключает ограничение скорость входящего/исходящего потока

Автобан!

"Auto BAN"

Здесь вы можете настроить параметры блокирования так называемых "халявщиков", тоесть участников обмена у которых тот или иной параметр на ваш взгляд слишком мал.

По умолчанию отключен

Бан если слотов менее - блокирует пользователя если у него открыто слотов меньше указанного числа

Бан если шара менее, Gb - блокирует если его шара меньше указанного

Бан если лимитер ниже, Kb - блокирует если ограничие отдачи у пользователя больше чем указано

Незаметный бан - режим невидимости, то есть юзер видит стандартное "нет свободных слотов"

Всегда в ЛС - отправить сообщение, дабы известить пользователя о том, почему не может скачать у вас файлы

Период сообщений (0 - выключено), мин - посылать сообщение отключенному пользователю через данный промежуток времени, при условии того что он до сих пор пытается что-то скачать

Сообщение - текст, посылаемый забаненому

Примечание: если стоит опция "Экстра слот тем, с кого сейчас качаю" то для того пользователя автобан не распространяется на время действия опции!


Внешний вид

А теперь то, что мы видим при каждом запуске FlylinkDC++


Строка меню

"Файл"

Открыть список файлов - открывает сохраненный на компе список файлов

Открыть свой список файлов - открывает ваш список файлов, то что видят другие пользователи

Match downloaded lists

Обновить список файлов - обычно программа сама обновляет список через 60 минут, нажав на это вы можете обновить в любой момент (например если вы расшарили что то еще, то нажать надо обязательно)

Папка для скачивания - открывает папку куда сохраняются скаченные файлы

Быстрое соединение - быстрое соединение с хабом

Перенаправление

Переподключение - переподключиться к хабу (например после изменения данных о себе)

Настройки - открывает меню настроек

Получить TTH файла - показывает TTH выбранного файла

Выход - закрыть программу

"Вид"

Недавние хабы - лог недавно подключенных хабов

Избранные хабы - добавление/удаление хабов

Друзья - можно настроить действия для определенных пользователей

Поиск \

Авто-поиск \ Читам тут

Поиск-шпион /

CDM отладчик

Блокнот - встроенный блокнот для заметок

Статус хеширования - если вы выбрали фоновое хеширование, то нажав здесь увидите прогресс

остальное: включают или отключают дополнительные панели

"Передачи"

Очередь скачивания - показывает окно состояния ваших закачек

Завершенные скачивания - то что вы скачали ха этот сеанс

Ожидающие юзеры - пользователи, которые ожидаю скачивания от вас

Завершенные отдачи - то, что у вас скачали

Сетевая статистика - статистика скорости скачивания/отдачи

"Окно"

ну тут все понятно

Это порядок расположения окон

Закрытие различных окон

Открытые окна (отмечено активное окно)

"Помощь"

Информация о программе

Online справка DC++

Перейти на форум о FlylinkDC++

Открыть файл справки


Панели

"Панель управления"

почти все элементы уже описаны, кроме некоторых. их мы и рассмотрим:

включает/выключает автобан участников у которых количество слотов меньше 5 (сейчас включено)

переключает ваш статус в состояние "ушел"

выключить компьютер через ...с простоя (настройка)

включить/выключить ограничение скорости (включено)

проверить обновление

включить/выключить звук

"Панель управления плеером"

стандартные кнопки управления - ничего нового, кроме

Показывать спам от проигрывателя в главном чате - после нажатия этой кнопки в главном чате появиться надпись примерно такого вида

настроить можно здесь

"Строка состояния"

на ней отображается:

· Текущее действие программы (...ищутся альтернативные источники...)
· Ваш статус (Ушел)
· Объем вашей шары (74,45 ГБ)
· Количество подключенных хабов (4)

H:4/0/0
нормальных хабов/зареген на/оператор
· Свободных слотов/минислотов (0/4)
· Скаченно в текущей сессии (113)
· Отдано в текущей сессии (300)
· Скорость скачивания
· Скорость отдачи
· Время до выключения компьютера

"Передачи"

Текущие скачивания/отдачи

"Что означает цвет?"

Зеленый - это значит что идет скачивание

Красный - отдача

Розовый - неизвестно сколько слотов

Серый - с тебя качает пользователь у которого >=5 и <10 слотов - кандидат на бан

Черный - качает пользователь у которого слотов >0 и <5 - этого надо либо забанить либо ограничить в скорости, чтобы не наглел


Окно чата

тут ничего нового

строка ввода текста

P.S: для перехода на написания второй строки нажмите Ctrl + Enter

нажав сюда вы увидете смайлы. (щелчок правой кнопкой мыши - выбор коллекции смайлов)


Команды чата

Команды для отправки в чат

Главный чат

/join <hub-ip>

Подключиться к <ip-хаба>. Смотри также Открывать новое окно при использовании /join.

/ts

Включает или отключает показ времени сообщений.

/showjoins

Включает или отключает показ пришедших/ушедших

/favshowjoins

Показывает приход/уход Друзей. Не требует включенного /showjoins

/userlist

Показывает/скрывает юзер-лист

/connection

Показывает IP и порт, по которым FlylinkDC++ позволяет подключаться другим пользователям. Если IP или порт неправильные, вы не сможете скачивать у некоторых пользователей. Работает только в активном режиме - IP и порт не используются в пассивном.

/favorite

/fav

Добавить текущих хаб (вместе с ником и паролем, если используется) в Избранные Хабы

/removefavorite

/removefav

Удалить текущих хаб из Избранных

/pm <user> [message]

Открыть приватный чат с пользователем и отправить ему сообщение, если оно было указано

/getlist <user>

Скачать файл-лист с пользователя.

Личные сообщения

/getlist

Скачать файл-лист с пользователя.

/grant

Дать Экстра-слот на 10 минут.

/favorite

/fav

Добавить пользователя в Друзья

Главный чат и Личный

/refresh

Обновить шару вручную. FlylinkDC++ автоматически обновляет каждый час (значение по умолчанию)

/slots <number>

Установить чисто слотов. Если вы установите меньше чем было, скачивания не оборвутся

/search <string>

Начать новый поиск по введенной строке.

/close

Закрыть текущее окно.

/clear

Очистить текущее окно от текста.

/flylinkdc++

Отобразить в чате версию клиента.

/away [message]

Установить статус "Ушел". На новые приватные сообщение единожды будет послан текст, если указан. По умолчанию можно выставить в настройках Внешний вид

/rebuild

Пересобрать фалы HashIndex.xml и HashData.dat files, Удаляя значения тех файлов, которых больше нет, или старых которые изменились. Может вызвать зависание программы до тех пор, пока процесс не завершиться!

/log <status, system, downloads, uploads>

Если параметр не указан, откроется лог для хаба или Личного чата, в приложении Windows определенного для этого типа. Если параметр указан, откроется соответствующий лог (если таковой имеется). Лог статуса доступен только в окне хаба.

/help

Показать доступные команды. (Некоторые из представленных здесь.)

/u <url>

Открыть браузер с текущей страницей.


Список пользователей

а теперь давайте разберемся, что есть что.

Ник - это понятно, если нет читаем

Шара - аналогично

Описание - пояснение

Слоты - количество открытых слотов

Скорость отдачи - зарегистрированая скорость отдачи на человека

Точная шара - размер шары в байтах

Тег

Тег - что это?

посмотрим из чего он состоит. выпишем для рассмотрения такую строку:

<FlylinkDC++ V:(r155),M:A,H:4/0/0,S:10,L:10>

V - версия DC++ у пользователя

М - активный/пассивный режим

Н

х - количество хабов, к которым вы подключены, где вы не зарегистрированы

y - количество хабов, к которым вы подключены, где вы зарегистрированы

z - количество хабов, к которым вы подключены, где вы - оператор

S - количество слотов

L - если скорость аплоада ниже этой величины, то DC++ автоматически открывает новый слот (функция действует только тогда,когда включена в настройках)

Все вышеперечисленные значения изменяются каждые 1-2 минуты.

Соединение - скорость соединения (на самом деле она у всех одинаковая)

Версия - версия проги

Хабы - количество хабов

Режим - активный/пассивный (если не знаем, читаем тут)

Что обозначает цвет пользователей?!

Цвет можно посмотреть в настройках программы и задать на свой вкус

Поиск пользователей по критерию

Если пользователей очень много, или вы просто хотите найти всех тех, кто удовлетворяет вашему запросу нужно:

1. ввести ваш критерий
1. выбрать по какому признаку отсеить


Избранные хабы

Колонки

Авто-соединение / Название

Имя хаба. . Если отмечено, DC++ автоматически подключится в этому хабу при запуске.

Описание

Описание хаба

Ник

Если хотите использовать определенный ник для этого хаба

Пароль

Если вы оператор, зарегистрированный пользователь, то впишите пароль сразу, чтобы потом не вводить каждый раз.

Сервер

ip или DNS хаба

Описание

Описание для этого хаба

E-mail
Почта для этого хаба

Кнопки

Новый...

Добавить новый хаб в избранное

Свойства

Изменить свойства хаба

Удалить

Удалить выбранные хабы из избраного.

Вверх

Переместить выше. Если несколько хабов отмечены на авто-подключение, то этот хаб будет подключатся первее.

Вниз

Переместить ниже. Если несколько хабов отмечены на авто-подключение, то этот хаб будет подключатся позже.

Соединение

Подключится к выделенным.

Создание / редактирование хаба

Показ вх/выходящих
Пазывает кто пришел, а кто ушел из хаба\

Спрятать шару на этом хабе
Ваша шара равна нулю

Исключить хаб из автопроверки на фейк
Отключить автобан для этого хаба

Имитация программы
Выберите под кого хотите "косить"

Raw commands - только для ОПов и Админов. Впишите сюда команды для хаба если, есть.


Друзья

Авто-выдача слота / Ник

Ник пользователя. Отметьте чек-бокс для выдачи авто-слота. Если отмечено, FlylinkDC++ автоматически выдаст слот пользователю, даже если у вас закончились свободные

Хаб

На каком хабе

Время (полседнее)

Последний раз замечен.

Описание

Пару слов о...

Супер юзер
Ограничения не действуют

Ограничить скорость
Скорость можно ограничить по вашему выбору

Игнорировать личные сообщения
Не получать ЛС от пользователя

Слоты
А сколько у него их...?


WebServer

В DC++ существует возможность наблюдать за ходом работы удаленно, используя встроенный WebServer.

Что для этого нужно?

· Включить в настройках эту возможность.
· Задать порт, через который будет осуществляться наблюдение.
· Сделать портфорвардинг этого порта

Как осуществить?

· Перемещаемся в Настройки => Дополнительно и включаем опцию
· Указываем номер порта/логин/пароль
· Настраиваем модем (читаем раздел Портфорвардинг)
· Где-то на другом компьютере открываем браузер и вводим

http://<ip компа с клиентом>:<порт>/

Вот и все!


Поиск. Виды поиска

В DC++ существует три вида поиска.

Обычный поиск – представляет собой систему сканирования подключенных к хабу ресурсов, с заданными параметрами. Поиск можно проводить по имени, размеру и типу файла. Например, вписав в поле поиска avi, вы по результатам поиска получите список доступных видео-файлов с расширением .avi

Если в поле «Искать» ввести имя (расширение) искомого файла, а в поле «size» его предполагаемый размер, будет произведен более точный поиск, чем просто по имени. С помощью выпадающего меню «Тип файла» можно задать также и тип файла, для получения максимально точных результатов.

Авто-поиск - предназначен для автоматического нахождения файлов по заданным ключевым словам. При открытии файл-листа все файлы, содержащие ключевое слово, будут отображаться в папке с заданным названием, выделенным жирным.

Пример: Надо найти все фильмы в формате avi, которые есть у этого пользователя. Настраиваем ADL-поиск: строка поиска - "avi", тип поиска - имя файла, папка для результатов - "Фильмы". Теперь при открытии любого файл-листа все файлы, содержащие строку "avi" в имени или расширении, будут продублированы в папке <<Фильмы>>

Поиск-шпион – Search Spy, отображает все поисковые запросы к хабу(-ам) от всех подключённых к нему юзеров. Поисковые запросы от каждого юзера хаб рассылает всем остальным подключенным к нему пользователям, Поиск-шпион эти полученные DC-клиентом от хаба запросы и отображает единым списком. Щелкнув правой кнопкой мыши по какой-либо строчке с текстом запроса, вы можете сами запустить по нему поиск.


настройки фаерволов

Настройки программных фаерволов (если есть другие - кидайте скрины с описанием)

Если Вы работаете в активном режиме (крайне рекомендуется), необходимо разрешить входящие TCP и UDP порты, указанные в настройках (чтобы клиент их не менял, необходимо выбрать тип соединения "Firewall with manual port forwarding"), и любые исходящие соединения в локальной сети. Для пассивного режима открытых входящих портов не требуется.

Брандмауэр Windows XP SP2

Пуск —> Выполнить.

в поле ввода вписываете:

netsh.exe firewall add allowedprogram program = C:\FlylinkDC\FlylinkDC.exe name = FlylinkDC = ENABLE

и нажимаете OK.

Это приводит к тому, что в фаерволе автоматически прописывается правило разрешающее сетевую активность FlylinkDC++

Agnitum Outpost Firewall

Параметры —> Приложения... —> Добавить... —> Выбираете программу StrongDC.exe в той папке, куда вы устанавливали клиента —> Щёлкаете на только что добавленную программу —> Изменить —> Создать правило... —> Создать.... Правило должно быть таким:

"Разрешить все"

OK —> OK —> OK

В русской версии вместо"Trusted Applications" написано "Доверенные приложения" не путаем!

Cкрины настроек аутпоста (c) <Squork>

Касперский

Выключить "режим невидимости".

+ два правила.

\


Этикет

Правила этикета для пиринговых сетей

Хабы и правила

· Когда Вы заходите на хаб, вы должны прочитать правила. Обычно хаб посылает их вам когда вы входите (или в главный чат или ЛС). Правила могут быть разнообразные.
· Операторы хаба (иконка с ключом) могут забанить Вас, если сочтут нужным. Большинство операторов дружелюбны, некоторые нет. Недружелюбный оператор, обычно, всегда прав... но только на этом хабе. Если недружелюбные операторы делают ваше прибывание на хабе не комфортным, покиньте его и присоединитесь на другой. Есть еще много других хабов и людей, которые оценят ваши файлы.

Расшаривание файлов

· Не расшаривайте файлы, которые не хотите скачивать сами. Примеры файлов, которые никому не нужны:
· Папка Windows
· Папка Program Files
· Папка Documents and Settings
· Корзина (если они вам не нужны, так зачем другим?)
· Homework / e-mails / temp files / cookies
· Незавершенные файлы
· Не отключайтесь от хаба, когда Вы скачиваете какие то файлы. (DC++ пользователи могут поставить опцию для запрета скачивания тех, кто отключен от хаба.)
· Расшаривание множества интересных файлов способствует развитию сети.

Просьба дать слот

· Прочитайте сначала описание. Если там написано "NO SLOTBEGGING", то просьба дать слот - не самая лучшая идея. Дождитесь своей очереди.
· Будьте вежливы. Будьте еще вежливее, если пользователь расшарил болшье чем остальные, а так же больше чем Вы.
· Перед просьбой о слоте, определитесь, что вы хотите скачать. Некоторые пользователи имеют предпочтение на раздачу того или иного материала. Не просите слот для новинок. Наиболее вероятно то, что за этим файлом уже стоит большая очередь. (Помните что исходящие канал ограничен и нет возможности раздавать слоты каждому индивидуально, скорость будет стремиться к нулю).

Разное

· Не спрашивайте о файлах в главном чате. Исключение, когда вы искали, но поиск не дал результатов и вы надеетесь, что ктото хранит файл на внешней среде.
· Не используй через мерные знаки препинания. Особенно, неоднократное исльзование (больше двух или трех) "?", "!" создают впечатление, что Вы являетесь еще маленьким ребенком. Тоже самое относится к большим буквам.


"Эволюция"

Отличительные особенности FlylinkDC++

Ревизия (256) 14.04.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r256.exe

http://ppa.leschat.net/setup/FlylinkDC-r256.rar

http://ppa.leschat.net/setup/FlylinkDC-r256-src.rar

[-] отключил IP фильтр на операцию поиск.

[*] оптимизация функции memzero (AMD, MMX & SSE) [ApexDC++1.0.0 beta2]

[*] баго-фиксы [ApexDC++1.0.0 beta2]

[*] по умолчанию URL скрипта определения IP установил в "http://flylinkdc.leschat.net/getip.php"

[+] хаб-лист г.Запорожье (сеть Homenet.zp.ua)

[+] хаб-лист г.Москва (Бирюлево)

[+] хаб-лист г.Санкт-Петербург (SilverNet)

[+] хаб-лист г.Москва (Speedyline)

[+] хаб-лист г.Москва (Net By Net)

[+] хаб-лист г.Москва (Тушино Телеком)

[+] хаб-лист г.Москва (Корвет)

[+] хаб-лист г.Королев (Каскад+)

[+] хаб-лист г.Кемерово ( GoodLine(E-Light) )

[+] хаб-лист г.Луганск ( Луганские Домашние сети )

Ревизия (255) 11.04.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r255.exe

http://ppa.leschat.net/setup/FlylinkDC-r255.rar

http://ppa.leschat.net/setup/FlylinkDC-r255-src.rar

[+] Мерж ApexDC++ 0.4.0 s15 (с) SMT

+ открытие файла из списка, если он есть в шаре [necros]

* вернул настройку "Filter kick and NMDC debug messages"

* оптимизировано использование процессорного времени при большом игнор-листе

! исправлены глюки в списке юзеров [thnx RX-3200]

! разблокировка заблокированного паролем клиента, при клике на magnet-ссылку

+ "поиск альтернатив" для выбранной отдачи

+ копирование магнет-ссылок для вставки на форумы

+ подменю "копировать" в списке активных соединений

+ спросить слот для закачки с множеством источников (у одного юзера на разных хабах повторно не спрашивает)

+ настраивается действие на двойной клик в списке любимых юзеров

* обновлены используемые в проекте библиотеки, оптимизирована структура проекта, улучшена общая стабильность

[+] Мерж ApexDC++ 0.4.0 mod3 (с) BugMaster

+ исправления по утечки памяти

+ оптимизация кода

+ обновлена bzip2 до версии 1.0.4

[*] STLPort r3001

[*] MyWTL (r49) http://zarezky.spb.ru/projects/my_wtl.html

Ревизия (254) 6.04.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r254.exe

http://ppa.leschat.net/setup/FlylinkDC-r254.rar

http://ppa.leschat.net/setup/FlylinkDC-r254-src.rar

[*] STLPort r2997

[*] MyWTL r48 http://zarezky.spb.ru/projects/my_wtl.html

[*] Обновление Loki::AssocVector

[+] Исправлен CustomLocations.ini и хаб-лист г.Запорожье (сети BisCom и 16X)

[+] хаб-лист г.Москва (Konkovo.NET)

[+] хаб-лист г.Москва (StarLink TeleCom)

[+] хаб-лист г.Москва (Бирюлево)

[+] хаб-лист г.Балаково (Волга-Телеком)

[+] хаб-лист г.Воркута (Воргашорские ЛС)

[+] хаб-лист г.Химки (bigtelecom)

Ревизия (253) 24.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r253.exe

http://ppa.leschat.net/setup/FlylinkDC-r253.rar

http://ppa.leschat.net/setup/FlylinkDC-r253-src.rar

[*] STLPort r2979

[*] обновление WTL

[!] подправлена работа с памятью

[*] переименовал хаб-лист "г.Тула (Домолинк)" в г.Тула + область (Домолинк)

[-] убрал из хаб-листов г. Алексин

[-] убрал из хаб-листов г. Новомосковск

Ревизия (252) 21.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r252.exe

http://ppa.leschat.net/setup/FlylinkDC-r252.rar

http://ppa.leschat.net/setup/FlylinkDC-r252-src.rar

[*] STLPort r2972

[!] исправлена локализация Украинского языка.

[+] хаб-лист г.Новомосковск (Домолинк)

[+] хаб-лист г.Москва (Цитус)

[+] хаб-лист г.Москва (Butovo.com)

[+] хаб-лист г.Мытищи (Никос)

[+] хаб-лист г.Рига (tele2)

[+] хаб-лист г.Полтава (поиск)

Ревизия (251) 18.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r251.exe

[+] исправление в хаб-листах г.Тулы

Ревизия (250) 18.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r250.exe

http://ppa.leschat.net/setup/FlylinkDC-r250.rar

http://ppa.leschat.net/setup/FlylinkDC-r250-src.rar

[+] SkazochNik создал "зеркало" сайта http://forestelf.net/

(на leschat.net много забаненых IP диапазонов и некоторые города не могут заходить на сайт)

[!] исправлена установка (перетирался IPTrust.ini для сетей Тулы)

[*] STLPort r2967

[+] хаб-лист г.Москва (Мигтелеком)

[+] хаб-лист г.Санкт-Петербург (HomeForce)

[+] хаб-лист г.Хабаровск (Востоктелеком)

[+] исправлены хаб-листы г.Тула

Ревизия (249) 17.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r249.exe

http://ppa.leschat.net/setup/FlylinkDC-r249.rar

http://ppa.leschat.net/setup/FlylinkDC-r249-src.rar

[*] STLPort r2966

Мерж DC++ svn-r726

[bug 1104] Better error message on dupe source (thanks ullner)

[bug 1152] Only refresh if there are directories shared (thanks ullner)

Ревизия (248) 15.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r248.exe

http://ppa.leschat.net/setup/FlylinkDC-r248.rar

http://ppa.leschat.net/setup/FlylinkDC-r248-src.rar

[+] Обновление WTL (build 7070) 3/11/07

[+] Исправлена загрузка последней строки правил IP-фильтра

Ревизия (245) 10.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r245.exe

http://ppa.leschat.net/setup/FlylinkDC-r245.rar

http://ppa.leschat.net/setup/FlylinkDC-r245-src.rar

[*] STLPort r2951

[+] копирование магнитиков в фомате веб-ссылки (с) necros

[~] Переведен IP Filter (все вынесено в Russian.xml)

[~] Несколько модификаций в IP Filter для красоты...

[+] обновлены хаб-листы Тулы и Алексин

[+] хаб-лист г.Шебекино (Домолинк)

[+] хаб-лист г.Апатиты (relant)

[+] хаб-лист г.Краснознаменск (Телеком-Сервис)

[+] хаб-лист г.Тамбов (ЦентрТелеком)

[+] хаб-лист г.Сергиев Посад (Инфотелеком)

[+] хаб-лист г.Сергиев Посад (КСИТ)

Ревизия (244) 4.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r244.exe

http://ppa.leschat.net/setup/FlylinkDC-r244.rar

http://ppa.leschat.net/setup/FlylinkDC-r244-src.rar

[+] исправление CustomLocations.ini для Тулы и Алексин

[+] установка не переписывает IPTrust.ini если он уже есть.

Ревизия (243) 4.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r243.exe

http://ppa.leschat.net/setup/FlylinkDC-r243.rar

http://ppa.leschat.net/setup/FlylinkDC-r243-src.rar

[+] В дистрибутив включено описание IPTrust.ini для Тулы.

Ревизия (242) 4.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r242.exe

http://ppa.leschat.net/setup/FlylinkDC-r242.rar

http://ppa.leschat.net/setup/FlylinkDC-r242-src.rar

[+] Добавлена IP фильтрация (меню-настройка-IP Filter)

возможность вводить доверенные зоны (файл Settings\IPTrust.ini)

Пример:

# Lipetsk-Domolink - IP

#195.34.224.1-195.34.255.254

#192.168.0.1-192.168.255.254

#172.16.0.1-172.31.255.254

#10.0.0.1-10.255.255.254

Для активации - опишите свои диапазоны.

[+] мерж изменений DC++ r701

Ревизия (241) 1.03.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r241.exe

http://ppa.leschat.net/setup/FlylinkDC-r241.rar

http://ppa.leschat.net/setup/FlylinkDC-r241-src.rar

[!] Исправлено возможное падение в ChatBot::onUserAction

[*] Обновление WTL (build 7058) 2.27.07

[*] Обновление STLPort r(2943)

[+] Хаб-лист г.Амурск

Ревизия (240) 28.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r240.exe

http://ppa.leschat.net/setup/FlylinkDC-r240.rar

http://ppa.leschat.net/setup/FlylinkDC-r240-src.rar

[+] Хаб-лист г.Владивосток

[+] Вернул возможность включения веб-сервера (+ перевел его на кодировку 1251)

[-] Убрал коррекцию Чешского языка

Ревизия (239) 26.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r239.exe

http://ppa.leschat.net/setup/FlylinkDC-r239.rar

http://ppa.leschat.net/setup/FlylinkDC-r239-src.rar

Мерж изменений из mod-s14 (с) SMT

+ улучшен автопоиск альтернативных источников

- убрал настройку "Filter kick and NMDC debug messages"

+ новые возможности чат-ботов: управление закачками, слотами, чат в хабе

+ пример бота, дающий слот по запросу "дай слот"

@ в новых версиях ApexDC-mod/FlylinkDC++ могут появиться более полезные боты

! исправлено зависание при получении ЛС

* изменения в системе обработки сообщений хаба, должна улучшится стабильность

+ можно включить автосообщение в ЛС при выдаче слота

+ защита паролем доступа в ЛС, выдача предупреждающего сообщения. некоторым пользоваетелям можно настроить доступ в ЛС без пароля (анти-игнор)

! поиск в найденном выполняется без учёта регистра (для не-ascii знаков тоже)

! исправлено зависание при выборе шрифта

! обезглючено окно закачек: иногда некоторые папки становились невидимыми

+ копирование в буфер обмена magnet-ссылок, TTH и т.п. сразу для нескольких выделенных файлов в окнах поиска, очереди закачек, окне с файл-листом

+ вызов "поиска альтернатив" из окна поиска для нескольких выбранных файлов

[+] Хаб-лист г. Белгород

[+] Хаб-лист г. Старый Оскол

[+] Хаб-лист г. Реутов

Ревизия (238) 25.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r238.exe

http://ppa.leschat.net/setup/FlylinkDC-r238.rar

http://ppa.leschat.net/setup/FlylinkDC-r238-src.rar

[+] Албанский русик

[+] Обновлена графика [KSiON]

[+] Хаб-лист г. Харьков

[+] Хаб-лист г. Алексин

Ревизия (237) 22.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r237.exe

http://ppa.leschat.net/setup/FlylinkDC-r237.rar

http://ppa.leschat.net/setup/FlylinkDC-r237-src.rar

[+] CustomLocations.ini г.Липецк (сеть ЛИС http://www.lis.su/)

Ревизия (236) 21.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r236.exe

http://ppa.leschat.net/setup/FlylinkDC-r236.rar

http://ppa.leschat.net/setup/FlylinkDC-r236-src.rar

[!] Исправлено зависание при личках [SMT] (у кого стабильно вешалось - просьба сообщить о пропадании эффекта - ppa@lipetsk.ru)

[^] сборка с обновленной STLPort r2929

[^] InnoSetup 5.1.10

Ревизия (235) 20.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r235.exe

http://ppa.leschat.net/setup/FlylinkDC-r235.rar

http://ppa.leschat.net/setup/FlylinkDC-r235-src.rar

[*] Исправлен хаб-лист г.Ульяновск

[+] Исправлен CustomLocations.ini и хаб-лист г.Запорожье (сеть BisCom)

[-] Убрал смайл с какашкой

Ревизия (234) 17.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r234.exe

http://ppa.leschat.net/setup/FlylinkDC-r234.rar

http://ppa.leschat.net/setup/FlylinkDC-r234-src.rar

[!] исправлен баг с командой /r (сломали в r233)

Ревизия (233) 16.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r233.exe

http://ppa.leschat.net/setup/FlylinkDC-r233.rar

http://ppa.leschat.net/setup/FlylinkDC-r233-src.rar

[+] хаб-лист г.Уфа

[+] CustomLocations.ini г.Запорожье (сеть BisCom)

Мерж изменений от [Drakon]

[+] Добавлены почти все известные команды в список /help

[+] Полностью русифицировано описание команд в /help

[~] Поправлено английское описание команд

[+] Русское описание команд вынесено в Russian.xml (без него будут английские)

[~] Предупреждение о пассиве в русике (без него будет английское)

[+] Программа автоматом при запуске бэкапит настройки

функцию бэкапа можно включить-отключить из меню! Вкладка "Дополнительно"

[~] Полная русификация ADL-help (русик от M.S.A)

[+] Русификация ADL выведена в Russian.xml

Ревизия (232) 8.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r232.exe

http://ppa.leschat.net/setup/FlylinkDC-r232.rar

http://ppa.leschat.net/setup/FlylinkDC-r232-src.rar

+ добавлена опция отключения расширенной раскраски прогрессов отдачи (меню-настройки-внешний вид-настройки) [Дракон]

+ обновлена графика [KSiON]

+ для Тулы обновлен CustomLocations.ini + скрипт определения IP http://anton.tula.net/getip.php

+ исправлено падение в FileChunksInfo::addChunkPos

+ обновил STLPort до r2899

+ хаб-лист г.Ульяновск

+ хаб-лист г.Минск (БГУ)

+ г.Запорожье (сеть BisCom) по умолчанию выставляется тип подключения: прямое

Ревизия (230) 5.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r230.exe

http://ppa.leschat.net/setup/FlylinkDC-r230.rar

http://ppa.leschat.net/setup/FlylinkDC-r230-src.rar

+ Добавлены "горячие кнопочки" на некоторые операции [Дракон]

+ Обновлен хаб-лист г. Волжский

+ Добавлен г.Запорожье (сеть BisCom)

Ревизия (229) 2.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r229.exe

http://ppa.leschat.net/setup/FlylinkDC-r229.rar

http://ppa.leschat.net/setup/FlylinkDC-r229-src.rar

Мерж mod-s13.4 (с) SMT

! исправлен глюк 13.3: пропадает "информации о юзере"

! исправлено зависание

Ревизия (228) 2.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r228.exe

http://ppa.leschat.net/setup/FlylinkDC-r228.rar

http://ppa.leschat.net/setup/FlylinkDC-r228-src.rar

+ обновил STLPort(r2887)

+ обновил WTL-cvs

+ отвязка от SimpleIdentity

Мерж mod-s13.3 (с) SMT

+ IP в "информации о юзере"

+ при получении ЛС мигает значок, если программа свёрнута в трей

+ подключаемый бот для ответа на ЛС (ChatBot.dll)

+ примеры двух ботов (на delphi для простоты изучения)

+ опция "дать экстра-слот" на произвольное время

+ "информации о юзере" в списке ждущих пользователей

! исправлено меню юзера в чате (пропадали некоторые пункты)

Ревизия (227) 1.02.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r227.exe

http://ppa.leschat.net/setup/FlylinkDC-r227.rar

http://ppa.leschat.net/setup/FlylinkDC-r227-src.rar

+ Число слотов можно выставить до 500

+ Обновлен "тулбарчик" (с) KSiON

Ревизия (226) 31.01.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r226.exe

http://ppa.leschat.net/setup/FlylinkDC-r226.rar

http://ppa.leschat.net/setup/FlylinkDC-r226-src.rar

Мерж изменений mod-s13.2 (с) SMT

! исправлено подвисание

Ревизия (225) 30.01.2007

http://ppa.leschat.net/setup/SetupFlylinkDC-r225.exe

http://ppa.leschat.net/setup/FlylinkDC-r225.rar

http://ppa.leschat.net/setup/FlylinkDC-r225-src.rar

Мерж изменений mod-s13.1 (с) SMT

! исправлено неправильное отображение статуса оператора хаба (в s13)

! исправлено: не работало меню юзера в чате, если включен фильтр

+ список закачек: "поиск альтернатив" для нескольких выбранных файлов

+ список закачек: "поиск альтернатив" по двойному клику на закачку

+ "информации о юзере" в меню списка юзеров хаба и в меню чата хаба

+ сохранение экстра-слотов при перезапуске программы

+ в "информации о юзере" время истечения срока действия экстра-слота

+ копирование слова по двойному клику в окне ЛС в поле ввода

* отключение автобана для некоторых хабов (в свойствах хаба галка "Исключить из автопроверки на фэйк")

+ при закачке из окна поиска можно скачать файл в папку с тем же названием, как и у юзера, где лежит файл (избавляет от необходимости создавать папку вручную и потом выбирать её)

* восстановлена поддержка WMP (из ApexDC 0.4), которая была временно отключена из-за отстуствия у меня Windows Media SDK

* исправлены неточности в русификаторе

Ревизия (223) 27.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupFlylinkDC-r223.exe

http://ppa.leschat.net/setup/FlylinkDC-r223.rar

http://ppa.leschat.net/setup/FlylinkDC-r223-src.rar

+ Исправлено падение под эмулятором wine (linux)

http://iceberg.leschat.net/forum/index.php?showtopic=741

Ревизия (222) 24.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupFlylinkDC-r222.exe

http://ppa.leschat.net/setup/FlylinkDC-r222.rar

http://ppa.leschat.net/setup/FlylinkDC-r222-src.rar

+ Динамическая верхняя граница для "автобанов":

по шаре "своя шара" (но не более 20 гиг)

по слотам "сколько слотов у меня"/2 (но не более 15 слотов)

по лимиттеру "лимиттер у меня"/2 (но не выше 60 кб/сек)

+ Файл-листы хранятся с CID (возникли проблемы с их открытием)

Ревизия (221) 24.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupFlylinkDC-r221.exe

http://ppa.leschat.net/setup/FlylinkDC-r221.rar

http://ppa.leschat.net/setup/FlylinkDC-r221-src.rar

+ Добавлен конфиг хабов г. Волжский (сетки : StarNet, LanCom и PowerNET)

Ревизия (220) 24.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupFlylinkDC-r220.exe

http://ppa.leschat.net/setup/FlylinkDC-r220.rar

http://ppa.leschat.net/setup/FlylinkDC-r220-src.rar

+ Вернул возможность отключать смайлы.

+ Файл-листы хранятся в виде ника (датаи CID не добавляется)

Ревизия (219) 23.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupFlylinkDC-r219.exe

http://ppa.leschat.net/setup/FlylinkDC-r219.rar

http://ppa.leschat.net/setup/FlylinkDC-r219-src.rar

+ Переписал работу смайликов. Выполняется загрузка всех доступных схем из EmoPacks\*.xml (с исключением дубликатов).Решается "проблема" - Вы видите в чате странный текст вида :weird: и т.п. Это происходило когда у клиентов не совпадают активные типы смайлов (например Вы пользуютесь Kolobok, а другие PeerWeb)

+ Смайлы по умочанию выбираются - peerweb

+ Заменил иконки пользователей

Ревизия (218) 22.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupFlylinkDC-r218.exe

http://ppa.leschat.net/setup/FlylinkDC-r218.rar

http://ppa.leschat.net/setup/FlylinkDC-r218-src.rar

+ Ребрендинг - программа сменила имя на FlylinkDC++

Знаменательное событие: Ребрендинг программы! Отныне она называется FlylinkDC++

История развития DomolinkDC++

Спуститься вниз

Ревизия (214) 19.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r214.exe

http://ppa.leschat.net/src/DomolinkDC-r214-src.rar

Мерж изменений от mod-s13

! исправлена ещё пара источников случайных вылетов (непросто было найти)

+ отдельные значки для забаненых юзеров в списке друзей и для окна ЛС [vorm]

+ всплывающие подсказки не закрывают контекстные меню в других программах

! исправлен глюк с несохранением ширины и видимости столбцов во многих окнах

+ просмотр файл-списка подсвечивает файлы/каталоги из очереди закачек

+ в опциях эксперта можно настроить двойной клик по закачке - повторить соединение немедленно (force attempt)

+ в меню "информация по юзеру" статус юзера в фаворитах на всех хабах (если юзер занесен в фавориты)

+ запуск внешней программы для быстрого просмотра файлов (вкл. в advanced)

Ревизия (213) 17.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r213.exe

http://ppa.leschat.net/src/DomolinkDC-r213-src.rar

+ При подкраске "дубля" файла показываем путь, где это уже лежит у Вас на диске

+ Сборка на STL-svn 5.2 r(2858) https://svn.sourceforge.net/svnroot/stlport/trunk/STLport

+ В связи с проблемами IE (http://wingsforum.onego.ru/viewtopic.php?p=5&sid=5691c0352407a2f039b9d81736074529)

диалог запроса действия над "магнитами" всплывает всегда.

Ревизия (212) 17.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r212.exe

http://ppa.leschat.net/src/DomolinkDC-r212-src.rar

+ Исправлены пути к звукам [necros]

+ Обновление WTL

Ревизия (211) 16.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r211.exe

http://ppa.leschat.net/src/DomolinkDC-r211-src.rar

+ Заменил иконки панели инструментов

+ Убрал все оранжевое, не волноваться - лого скоро заменим на другое, пока считаем это закосом под серую темку Vista-ы :)

Ревизия (210) 15.01.2007 [базируется на Apex DC++ 0.4.0]

Всем тем, у кого стоит версия 206-209 срочно обновиться до 210

http://ppa.leschat.net/setup/SetupDomolinkDC-r210.exe

http://ppa.leschat.net/src/DomolinkDC-r210-src.rar

+ Собрал с поддержкой iTunes

+ В главном окне поправил колонку IP

+ откатил патч - http://forums.apexdc.net/index.php?showtopic=1201 - были жалобы на звисание (возможно не тут причина)

Ревизия (208) 14.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r208.exe

http://ppa.leschat.net/src/DomolinkDC-r208-src.rar

+ Поправлен путь в установке по умолчнию DefaultDirName={pf}\DomolinkDC++

+ исправлена локализация

Ревизия (207) 14.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r207.exe

http://ppa.leschat.net/src/DomolinkDC-r207-src.rar

+ Добавлены файлы Settings\CustomLocations.bmp и Settings\CustomLocations.ini с описанием подсеток: пока разделили Стринт и Домолинк кто знает другие диапазоны поправьте файлики и киньте на ppa@lipetsk.ru - включим в следующую версию

Ревизия (206) 14.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r206.exe

http://ppa.leschat.net/src/DomolinkDC-r206-src.rar

+ Бан по шаре нельзя поставить больше 20 гиг (c) Paul

+ SMT исправил баг случайного падения ApexDC++ 0.4.0 - http://forums.apexdc.net/index.php?showtopic=1201

Ревизия (205) 13.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r205.exe

http://ppa.leschat.net/src/DomolinkDC-r205-src.rar

+ Вернул колонки - "точная шара" и "хабы" (это оказалось нужно опам из Тулы и Харькова)

+ В установку добавлен предварительный просмотр видео AVIPreview.exe (135кб)

+ Сборка с обновленной WTL-cvs

Ревизия (203) 12.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r203.exe

http://ppa.leschat.net/src/DomolinkDC-r203-src.rar

Мерж с mod (с) SMT

mod-s12

+ выбор идентификатора клиента на хабе (PeerWeb, ApexDC или любой свой)

mod-s12.1

В контекстном меню пользователя сделано подменю 'Summary user report', там 3 раздела: ники юзера на разных хабах (проверяется по точному размеру шары и по IP, если есть). записи, проверенные по IP - с галочкой. раздел "юзер хочет скачать" - какие файлы ждёт в очереди, раздел "закачки с этого юзера" - что я хочу скачать (серые закачки - отключенные в списке источников) заголовок меню - информация о шаре, слотах, ограничениях галочка напротив хаба - юзер проверен не только по шаре, но и IP

+ многострочное окно ввода текста в чат/приват (включается в Appearance) [Decker]

+ исправлена подсветка при просмотре своей шары (иногда включалась)

Ревизия (202) 12.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r202.exe

http://ppa.leschat.net/src/DomolinkDC-r202-src.rar

+ Вернул возможность менять коллекции смайлов

+ Вернул стартовую сортировку по нику (было по шаре)

+ [Decker] Окошко для ввода сообщений расширил до 2-х строк (для перевода строки - жмем Ctrl+Enter)

Ревизия (201) 11.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r201.exe

http://ppa.leschat.net/src/DomolinkDC-r201-src.rar

+ В связи с введением функции "автобана", cнято ограничения на кол-во слотов (можно ставить от 1 до 99) значени по умолчанию = 15

+ Размер минислота можно уменьшить до 1М (было 8М)

+ Кол-во минислотов можно уменьшить до 3-х (было 5)

+ Разблокировано окошко - отношение слотов.

+ Добавлен кей /nologo - отключает показ сплеша окна при старте (полезно, когда программа в автозагрузке)

+ Добавлен кей /nocolor - отключает дополнительную подкраску прогрессов по кол-ву слотов в окне передачи.

+ Добавлен кей /stealth - клиент "косит" под StrongDC++ 2.03

Ревизия (200) 08.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r200.exe

http://ppa.leschat.net/src/DomolinkDC-r200-src.rar

+ К "автобану" добавлена функция - банить при попытки качать с нескольких хабов [necros]

+ Исправлена утечка в смайлах. [BugMaster] http://forums.apexdc.net/index.php?showtopic=1181&hl=

+ Исправлено падение [Decker] http://forums.apexdc.net/index.php?showtopic=1171&hl=

Ревизия (199) 07.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r199.exe

http://ppa.leschat.net/src/DomolinkDC-r199-src.rar

Мерж изменений из mod-s11

+ "Поиск-шпион" смотрит в шару и подсвечивает файлы и частичные закачки

+ "Поиск-шпион" показывает ip юзеров (и ники, если пассивный поиск либо раньше было соединение с этим IP)

+ поиск подсвечивает файлы, которые уже есть в шаре

+ опция "Экстра-слот тем, с кого сейчас качаю" (настройки-шара)

+ настраивается всплывающая подсказка и звук на событие "fav user ушёл с хаба"

Ревизия (198) 07.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r198.exe

http://ppa.leschat.net/src/DomolinkDC-r198-src.rar

- Убрал опцию "Не скачивать файлы, уже находящиеся в шаре" т.к. это может приводить к неверной скачки DVD "россыпью" в них есть VOB файлы, которые дублируются и находятся в любом пиратском DVD

- Слил все смайлики в одну кучу

- Для опов вернул позможность смотреть IP в чате.

- Исправлен баг http://forums.apexdc.net/index.php?showtopic=1171 [BugMaster]

Ревизия (197) 06.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r197.exe

http://ppa.leschat.net/src/DomolinkDC-r197-src.rar

+ Добавлены две коллекции смайлов

Kolobok

RadoX-EmoPack-V2.1

+ Определение IP адреса перекинул с внешнего адреса http://checkip.dyndns.org/ на локальный аналог http://ppa.leschat.net/getip.php (за скрипт спасибо SkazochNik-у) теперь кнопочка "Найти IP адреса" работает корректно в сети Domolink

+ В окне поиска спрятал пункт меню BITZI_LOOKUP

+ std::multimap перевел на hash_multimap

+ В r196 перепутал цвета пассива/актив

+ Запретил галку "эмуляция старого DC++ клиента"

Ревизия (196) 05.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r196.exe

http://ppa.leschat.net/src/DomolinkDC-r196-src.rar

+ в "автобане" можно поставить значение по шаре = 0 (также по умолчанию это значение поставлено в 0)

+ при активации фильтра - меняется иконка а не цвет юзера.

+ мелкие багофиксы

Мерж изменений с mod-s10.2

! Убран баг при добавлении ограничений на юзера, который уже вышел с хаба

! Убран баг при отображении списка юзеров хаба

Ревизия (194) 04.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r194.exe

http://ppa.leschat.net/src/DomolinkDC-r194-src.rar

- Косметический баг в окне очереди

Ревизия (193) 04.01.2007 [базируется на Apex DC++ 0.4.0]

http://ppa.leschat.net/setup/SetupDomolinkDC-r193.exe

http://ppa.leschat.net/src/DomolinkDC-r193-src.rar

Мерж изменений с mod-s10.1

* Цвет забаненых юзеров устанавливается в DCPlusPlus.xml, нода <BanColor>

! Устранено зависание при выборе шрифта всплывающих сообщений

! Исправлен предпросмотр всплывающих окон [necros]

+ Подсветка файлов и директорий из скачанного файл-списка,

которые есть в своей шаре [fulDC]

+ Показывает город пользователя в списке закачек (необходимо наличие

файлов CustomLocations.bmp, CustomLocations.ini в каталоге Settings)

+ столбцы IP, LOCATION в списке ждущих юзеров

* Улучшена раскраска в списке пользователей, ожидающих в очереди

* Выбор цветов автобана и дубликатов на странице "Colors&Fonts" [necros]

Ревизия (192) 03.01.2007 [базируется на Apex DC++ 0.4.0]

- Кол-во сегментов по умолчанию выставлено = 200 ( ранее было 50)

Ревизия (191) 03.01.2007

http://ppa.leschat.net/setup/SetupDomolinkDC-r191.exe

http://ppa.leschat.net/src/DomolinkDC-r191-src.rar

- к поиску добавлена новая группа CD-DVD Images { ".nrg", ".iso", ".mdf", ".mds", ".vcd", ".mds",".bwt",".ccd",".cdi",".pdi",".cue" }

- к группе "исполняемый файл" добавлено ".msi"

- к группе "сжатый" добавлено ".7z"

(Данное изменение будет работать только между пользователями DomolinkDC++ с версией больше r191

и в общем случае пока рекомендуется образы искать по маске *.iso и т.д.)

- Отключил yassl и toacrypt (размер exe уменьшился на 300К)

- Подсветка всех юзеров, потенциально попадающих под "автобан" ( + в списке ждущих юзеров)

(юзера, которые в текущей сессии попали под "автобан" продолжают подкрашиваться голубым цветом)

[!] Мерж изменений из ApexDC++ mod-s9.6 (http://portal.san.ru/forums/index.php?showtopic=2499)

+ у избранных юзеров добавлено игнорирование лимитера

(в чём-то дублирует мой режим SuperUser, но действует и на download limiter)

- удалёна перепроверка TTH после скачки каждого 64k блока (меньше юзается CPU)

! исправлен глюк с пропаданием подменю скорости

! убраны оповещения в трее и высплывающие окна при сообщениях автобана

+ в диалоге импорта магнет-ссылки кнопка "сохранить как"

+ добавлены ограничения скорости 128k, 256k (на самом деле это 142 и 333 kb/s;))

+ к имени файл-листа добавлена дата закачки

Ревизия (188) 27.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r188.exe

http://ppa.leschat.net/src/DomolinkDC-r188-src.rar

+ При активаци фильтра по юзерам все отфильтрованные временно

покрашиваются серым (так заметнее то, что активен фильтр)

+ Поддержка управления плеерами

+ Windows Media Player

+ Media Player Classic

- (iTunes пока вырезал как редкий вид плееров :)

Выбор плеера производится в Настройки->Дополнительно

Спам от Media Player пока не работает...

+ Исправлено падение на двойном клике по файлу после поиска.

+ Вернул патч от BugMaster деление на 0 (его не исправили в ApexDC++ 0.4.0)

(http://forums.apexdc.net/index.php?showtopic=1132&pid=9625&st=0&#entry9625)

+ Кнопочка "Настройки->Настройки соединения->Получить IP адреса" заблокирована т.к. возвращает

"левый адрес" cache.lipetsk.ru для юзерова без внешнего IP.

Ревизия (187) 27.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r187.exe

http://ppa.leschat.net/src/DomolinkDC-r187-src.rar

+ Вернул возможность подключения директом (нужно при работе модема в режиме моста)

+ Добавлены новые хабы

+ Убрал галку "Автоматическое добавление в очередь для совпадений из авто-поиска"

она вызывала переодическую закачку большого кол-ва файл-листов.

+ Добавлен файл DomolinkDC.pdb для "раскрутки стека" в случае падения.

+ В локализации исправлены ошибочки

+ Подправлен режим автобана - не банятся юзера

с лимитом = 0 или слотами = 0 (т.к. не известно сколько у них чего)

+ Подсказка по выбору IP адресов (выпадают все доступные сетевые интерфейсы) [Apex 0.4.0]

+ Расширена настройка всплывающих подсказок [Apex 0.4.0]

+ При сортировке по нику - друзья оказываются в начале списка [Apex 0.4.0]

[!] Мерж изменений от вышедшего ApexDC++ 0.4.0 http://www.apexdc.net/?id=changelog

[!] Мерж изменений из ApexDC++ 0.3.0s9.5

+

- возможность игнора опов в чате хаба

- авто-бан не применяется к юзерам, которым дали экстра-слот

- улучшено подменю 'User Waiting Files' (показывает слоты, шару, лимитер)

- уничтожена фича ApexDC: опы хаба всегда могут качать с минислотов,

файлисты и TTH частей файлов независимо от наличия свободных минислотов

- исправлен глюк со вставкой смайлов [BugMaster]

- отсылка бан-приватов без открытия окна

- не открывается окно привата при получении сообщения автоответчика на бан

Подробнее про "автобан":

Автоматический бан юзеров, у которых открыто мало слотов или маленькая шара

Настройки живут в закладке "fake detector/детктор читов". Если стоят нули, то по этому

условию не банится. Настройки авто-бана:

- ban if open slots less than (банить, если слотов меньше указанного числа)

- ban if shared less than (банить, если шара меньше указанного числа гигов)

- ban if upl speed limit less, Kb (банить, ограничена скорость закачек

менее чем указано)

- Repeat PM Period (повторять сообщение о бане в личку каждые NN минут).

сообщения появляются если юзер забаненный продолжает пытаться скачать файл.

если юзер меняет размер шары или слоты, либо меняются настройки авто-бана,

всегда посылается новое сообщение, даже если не прошло указанное время

ВНИМАНИЕ! если в этом поле 0, сообщения в личку не отсылаются

- Stealth Ban (невидимый бан) - юзер получает стандартное No Slots Available

и не может узнать, что скачка заблокирована баном

- Force PM (всегда в личку). обычно, если юзер пользуется ApexDC mod 9.5 или

выше (DomolinkDC++ r187 или выше), то сообщение о бане появлется в списке

закачек и личка не наполняется лишними сообщениями.

с этой опцией бан-сообщение всегда дублируется в личку

- Message on ban. позволяет указать сообщение с описанием своих условий

(сколько надо расшарить и открыть слотов), которое будет послано юзеру в личку

Если юзеру выдан автослот или экстра-слот, этот юзер никогда не банится.

Ревизия (183) 24.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r183.exe

http://ppa.leschat.net/src/DomolinkDC-r183-src.rar

+ Юзера попадающие в "автобан" в списках подкрашиваются цветом RGB(98,176,255)

Ревизия (182) 24.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r182.exe

+ На логотип натянули шапочку Дед Мороза! Спасибо KSiON

Ревизия (181) 24.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r181.exe

http://ppa.leschat.net/src/DomolinkDC-r181-src.rar

+ Добавлено слеш-окно на закрытие клиента (при большом кол-ве хабов этот процесс может занимать достаточно длительное время - 10...20 секунд)

+ Сортировка юзеров в хабах по умолчанию переведена на размер шары

+ Исправлены иконки (они немного искажались при темных темках)

Ревизия (180) 23.12.2006

+ В очереди ожидающих юзеров добавлены колонки "слоты" и "шара"

+ Изменение в локализации - "Всегда использовать пассивный режим для поиска (в DomolinkDC++ эта функция отключена!!!)" пассивный режим поиска используется только при работе в пассиве, в противном случае поиск автоматически переключится в активный.

+ Сборка выполнена в студии с установленным SP1 (Microsoft ® 32-bit C/C++ Optimizing Compiler Version 14.00.50727.762 for 80x86)

+ Doxygen-ом поправил граф включений (выкинул "кольцевые" include)

Ревизия (179) 22.12.2006

+ Заблокирован порт TLS прокидывать его в модеме теперь не нужно.

+ Заблокирован режим UPnP (WinXP)

Мерж изменений из ApexDC 0.3.0 mod 2 (Автор - BugMaster)

[!] исправлен глюк с периодическим вылетом (деление на ноль)

[!] исправлен неверный порядок колонок в некоторых вкладках (в прошлой версии я исправил в одном месте, но появились в другом)

[+] смайлы вставляются в позиции курсора, а не в конец

+ Обновление WTL 8.0 до (build 6356) 12/22/06

Ревизия (178) 20.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r178.exe

+ Исправлен косметический баг в диалоге "Детектор читов" (спасибо Vladimir V. Gubin)

+ мерж изменений из mod-s9.3

- исправлен глюк с мнимым увеличением шары (обнаружен AniNerbe, исправлен [Crise])

- автобаны по мин. размеру шары и количеству слотов. если указано доп. сообщение, то оно будет отправлено в личку (с переодичностью

30 минут каждому нарушителю)

- передача файл листов не автобанится - путь видят, что есть но скачать не смогут

- возможность менять число сегментов до 200 не прерывая закачку [BugMaster]

- испрален вылет на закачке файл-листов [BugMaster]

- улучшено подменю 'User Waiting Files' (не надо держать открытой очередь юзеров)

Ревизия (177) 20.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r177.exe

+ В окно передачи добавлена колонка - шара (если по ней отсортировать то легко закинуть в "бан-лист" "качков" с мелкой шарой)

+ "Автобан" по размеру шары минимальный размер = 5 гиг максимальный 50 настраивается в диалоге - Настройки -> Детектор читов в случае нарушения условий качек тихо обрубается с записью в логе

[DomolinkDC++][Autoban!][Slots<5 or Shared<10] User:[leo777] IP:[172.24.193.139] slots:[10] shared:[1 Gb]

+ Исправлен скрипт установки - дистрибутив сам находит путь, в который раньше ставилось приложение (спасибо Ramzes за коррекцию скрипта NSIS)

+ Снято ограничение на нижнюю границу автобана в 5 слотов кому нужно, может отключить функцию автобана выставив в настройках 0 попросили Питерские для них 5 многовато http://img146.imageshack.us/img146/351/2vh3.jpg)

+ Мерж изменений из ApexDC 0.3.0 mod (Автор - BugMaster) http://forums.apexdc.net/index.php?showtopic=1086

+ Мерж некоторых багофиксов из релиза DC++ 0.699

Ревизия (176) 19.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r176.exe

+ Исправлено падение на отрисовке прогресса в очереди закачек (когда качается "файл лист") в этом случае длина файл = uint64_t(-1) что приводило к "переполнению математики"

+ В "автобане" введено ограничение сверху - нельзя банить юзеров, у которых больше 15 слотов! Также нельзя выставить границу бана меньше 5

Мерж изменений из клиента ApexDC-s9.2:

+ если на поиск приходил ответ "файл есть частично", IP юзера не записывался в соответствующий столбец (нужно для статистики)

+ исправлено зависание в "добавить источники" (readd source)

+ Инструмент против папрашаек

:

Отображение ожидаемых файлов в контекстном меню юзера

(http://ppa.leschat.net/image/Image3.png)

+ Добавлена служебная функция генерации SQL инструкций INSERT для последующей заливки в базу данных лога по юзерам формат такой:

insert into IPLOG

(STAMP, CID, HUBIP, NICK, USERIP)

values

(

'19.12.2006 01:25',

'ZDNCUJT44EMXC7JR4F3OH3DW7N6V7AP2B2PYD5A',

'dc.leschat.net',

'stals',

'172.24.164.xxx'

);

Для активации режима, необходимо создать пустой файл с именем userip.log рядом с DomolinkDC.exe

Ревизия (175) 18.12.2006

+ Внутренняя сборка для теста.

Ревизия (174) 17.12.2006

http://ppa.leschat.net/setup/SetupDomolinkDC-r174.exe

+ Полностью исключена загрузка TLS

+ Добавлен интерфейс для настройки режима "авто-бана"

"Настройки->Детектор читов" по умолчанию включен порог слотов < 5

в режиме "автобана" клиент обрубается с записью в системный лог с сообщением вида:

[2006-12-17 13:29] [DomolinkDC++][blocked] UploadConnection: Slots < 5 IP:[172.24.168.196] User:[greenpsih]

+ Временно отключить режим "автобана" возможно первой кнопкой в главной панели инструментов.

+ Выборочно отключить режим "автобана" для пользователя можно занесением его в "друзья" но обязательно с автослотом.

Ревизия (173) 16.12.2006

+ По умолчанию выключен TLS

+ Стартовая версия "автобана" на 5 слотов

Ревизия (172) 15.12.2006

+ Если у юзера нет тэга (почему его нет, я пока не знаю) это проявляется не на всех хабах

и заметил я это на "мудачном дисконнекте"(dc2.leschat.net) вероятно это связанно с настройками хаба

а не с его названием :)

В случае отсустствие тэга нельзя определить кол-во слотов у клиента в таких случаях прогресс "качка" без тэга

отмечается другим цветом.

Ревизия (171) 14.12.2006

+ Если юзер в бане, то не пищит и не показывается в трее, что он "пришел"

+ Исправлен наезд панельки винампа на основную панель инструментов.

+ Выкинул офлайн справку в формате chm - уменьшился размер дистрибутива. (~2M)

+ Исправлен баг с определением слотов в окне передачи файлов (иногда неверно давало 0)

Ревизия (169) 12.12.2006

Влил изменения с ApexDC++ mod-s9

- Изменение upload скорости пользователя применяется "на лету", возможен

вызов из контекстного меню списка активных закачек (удобно для банов),

при необходимости юзер автоматически добавляется в favorites

- Улучшена стабильность, исправлен вылет при upload с ограничениями скорости

- Исправлено: забаненые юзеры не могли скачать файл-список (100 байт/сек)

http://ppa.leschat.net/setup/SetupDomolinkDC-r169.exe

Ревизия (168) 11.12.2006

+ Убрал покараску черным для режима Download.

+ Убрал команду whois

http://ppa.leschat.net/setup/SetupDomolinkDC-r168.exe

Ревизия (167) 11.12.2006

+ Качки с меньше 10 слотов красятся серым.

+ Добавлена проверка на новую версию при старте приложения

+ К избранным добавлена колонка "слоты" (если 0 то пользователя нет в онлайне)

+ По умолчанию включены смайлы "sio[smile]" (с) KSiON

+ Обновлена темка (с) KSiON

+ Выкинул команду whois она лезла во внешний инет если по ней жмякнуть

http://ppa.leschat.net/setup/SetupDomolinkDC-r167.exe

Ревизия (166) 10.12.2006

+ Добавлна коллекция смайлов SiO[SMiLE] | v1.0 Beta . 10.12.2006 | KSiON

+ У программы появилась оналайн справка http://ppa.leschat.net/ (внутренний трафик)

+ Обновление перкинул на адрес http://ppa.leschat.net/DomolinkDC_version.xml

+ Качки со слотами < 5 в прогрессе красятся черным цветом)

http://ppa.leschat.net/setup/SetupDomolinkDC-r166.exe

Ревизия (165) 9.12.2006

+ В окне передачи файлов добавлена колонка "Слоты"

+ M.S.A обновил справку

Ревизия (164) 8.12.2006

+ Вернул колонку IP во фрейме юзеров чата.

Ревизия (163) 7.12.2006

+ В дистрибутив добавлен файл изменений (DomolinkDC-patch.diff) на ApexDC++ 0.3.0

по нему можно узнать, что с программной стороны менялось в исходном коде Апекса

и чем от него отличается DomolinkDC++

r162 (6.12.2006)

+ M.S.A обновил хелп. (размер дистрибутива стал 12 мег)

+ Интегрировано новое описание настроек модемов от Berik-а в формате chm

(добавлена настройка ASUS-ов)

Ревизия (161)

+ Исправлена ошибка сортировки по размеру шары в гриде юзеров. (при клике по шаре - сортировалось по слотам)

Ревизия (160)

+ Исправлены орфографические ошибки в новой помощи

+ "Запуск" хелпа выведен в меню + на кнопку F1

+ Из окна юзеров выкинул еще пару лишних колонок

Ревизия (159) 3.12.2006

+ Исправлена утечка памяти при закрытии фрейма с хабом

+ Выкинул лишние колонки из списка юзеров (экономит память и меньше тормозит на слабых машинах)

+ Исправлены опечатки в локализации (спасибо Leonid Matsak )

+ Косметические исправления от M.S.A

+ Обновлена документация - автор M.S.A

+ Собрал с последней версией WTL (Windows Template Library - WTL Version 8.0 (build 6323) 11/19/06)

Ревизия (157) 30.11.2006

+ Обновлен инсталлятор до NSIS 2.22

+ Добавлены темки от апекса (я сам не пользуюсь)

+ Добавлены фичи от ApexDC++s8 (c) SMT

http://portal.san.ru/forums/index.php?showtopic=2499&st=0

+ Игнорирование приватных сообщений от выбранных пользователей

Сообщения блокируются только в случае, когда окно чата с пользователем

закрыто, если его открыть самому, можно общаться с заблокированным юзером

(удобно использовать против ботов)

+ Отказ подключения заданным пользователям (бан)

+ Режим "SuperUsers":

даже при установке upload speed limit, для таких пользователей скорость

не ограничивается. ширина канала, установленная в опции limit upload speed,

распределяется между всеми пользователями, а SuperUsers дополнительно могут

забрать остаток upstream-канала

+ Спам выделенных пользователей каким-то сообщением - для выпрашивания слотов.

функция "Private Message", везде, где выделено несколько пользователей

(проверено - работает в поиске и в списке источников у закачки)

сначала спрашивает, что послать, а потом отсылает сообщение всем выделенным.

текст сообщения запоминается для последующего использования. для старого

поведения (просто открыть приватные окна всем выбранным пользователям,

ничего не рассылая, нажмите "отмена")

{btw, кто будет стучаться ко мне таким способом, забаню навечно!}

+ добавлены столбцы "DNS" в список юзеров хаба, в список закачек/скачек,

в окно с результатами поиска. столбец показывает доменное имя, соответствующее

ip-адресу пользователя. возможные режимы поиска имён:

0 - отключен

1 - преобразование как только появится ip-адрес (результаты кешируются, но

всё равно возможно замедление работы клиента)

2 - отложенное преобразование. ip ставятся в очередь и преобразуются в имена

в фоновом режиме. можно указать время минимальное между DNS-запросами

настройкой DCPlusPlus.xml<DCPlusPlus/Settings/NsLookupDelay>.

при последующем использовании ip смотрим в кеш преобразованных адресов

настройка режима пока не вынесена в gui, настраивать можно в

DCPlusPlus.xml:

<DCPlusPlus>

<Settings>

<NsLookupMode type="int">1</NsLookupMode>

</Settings>

</DCPlusPlus>

по умолчанию включен режим 2 с задеркой 100 мс

Ревизия (156) 28.11.2006

* Исправлены опечатки в локализации (с) Squork

* "Медленные источники" теперь автоматически не отключаются - (с) M.S.A

Ревизия (155) 26.11.2006

С разрешения Berik-а в установку добавлена дока по настройки модемов и программы

+ Взято несколько патчей с модификации Апекса от SMT http://sourceforge.net/projects/apexdcspeedmod/

- Максимальное число сегментов поднято до 200

- при генерации файла Settings/exceptionsinfo.txt лог о предыдущем

сбое не удаляются, информация дописывается в конец файла.

- без PDB-файла Settings/exceptionsinfo.txt тоже создаётся, но с меньшим

количеством отладочной информации.

- исправлен баг, при котором все закачки апекса подвисают

в состоянии 'Connecting' (Соединение)

Ревизия (149) 15.11.2006

Число сегментов поднято до 40-ка (в оригинальных Strong/Apex максимум = 10)

данное изменение приводит к поднятию скорости закачки "распростаненных" файлов ( 700кб/c - 1 Мб/c)

Ревизия (147) 14.11.2006

DomolinkDC++ сменил базовую ветку на ApexDC++ 0.3.0

Изменения в ApexDC++ 0.3.0

* Merge: StrongDC++ 2.03 (cvs200)

* GUI: New interface (thanks RadoX, screenshots to follow)

* Feature: Can now receive external IP

* Feature: Ignored users list now editable via settings

* Feature: Format bold, italics and underline in chat (use *bold* /italics/ _underlined_)

* Feature: Email configurable per hub basis

* Feature: Protected prefixes

* Feature: Away message configurable per hub basis

* Feature: Show joins/parts configurable per hub basis

* Feature: Option to save settings window state

* Feature: Adjustable main chat buffer size (fulDC++)

* Feature: Option to enable $HubTopic support

* Feature: Option to start hubs minimized

* Feature: Added %[extra] to get ip/country in logs (e.g. [%Y-%m-%d %H:%M%[extra]] %[message])

* Feature: PG plugin updater system (new update once per month)

* Feature: More PG plugin anti-abuse checks

* Feature: Private Message window now shows hubname when user goes offline

* Feature: New chat commands:

o /discogs

o /wikipedia and /wiki

o /f for /foobar

* Fix: Crash related to partial transfer enchantment (thanks SMT)

* Fix: Issues regarding newlines in topics

* Fix: High CPU usage on ignore/unignore user

* Fix: Crash fixed in country code and IP feature (PrivateFrame)

* Fix: Country code and IP is shown with /me command as well

* Fix: PeerGuardian plugin no longer blocks hub Operators

* Change: Improvements to GUI (appearance page & others)

* Change: Input area for default away message reduced

* Change: Type /find to find text in main chat (previously /f)

* Change: More translatable strings

* Change: Misc page options rearranged a bit

* Change: Added Compile date to aboutbox and stats

* Change: Tray menu is non-functional if password protection on tray is enabled

* Removed: XP-styled menus (memory leak)

* Source: Obsolete files and unneeded local variables removed

Ревизия (99) 09.11.2006

[+] Оптимизирована скорость загрузка приложение.

[+] Малек подправлена локализация

[+] Влил некоторые исправления ошибок из кода StrongDC++ 2.03

Ревизия (96)

в строке заголовка окна и кнопка на панели задач - у тебя везде написано DomolinkDC++ (r**)

путь установки по умолчанию C:\program files\DomolincDC++

при установки убран задний фон

Ревизия (92)

Заменена графика

Ревизия (82)

Исправлен баг с русификацией

добавлены еще два дефолтных хаба

Ревизия (81)

Автоматическое подключение к 2-м Липецким хабам dc.leschat.net, dc2.leschat.net (второй не требует обязательно шариь шарить >=1 гиг)

Убрал поддержку локального WebServer-а

Исключил загрузку и поиск плагина PeerGuardian.dll (нужен для работы во внешней сети)

В настройках сети добавлена ссылка на тест портов (http://freelan.leschat.net/test.php)

Ревизия (70)

Вернул смайлики

Ревизия ...

Изменения относительно ApexDC++

Исключена начальная загрузка публичных хабов из инета (внешний трафик)

Удалена поддержка "GeoIP"(внешний трафик)

Отключена поддержка соединений с внешними хабами (внешний трафик)

Автоматическое подключение к Липецким хабам

dc.leschat.net

172.24.149.97

( при первом перезапуске после установки программы.)

Убрал поддержку локального WebServer-а

Исключил загрузку и поиск плагина PeerGuardian.dll (нужен для работы во внешней сети)

В настройках сети добавлена ссылка на тест портов (http://freelan.leschat.net/test.php)

Изменены установки по умолчанию

Интегрирована русификация интерфейса

Адрес 0.0.0.0 изменен на 192.168.1.12

Кол-во слотов открываемых по умолчанию выставлено в 5 (было 2)

Проставлены галочки:

"Не скачивать файлы, уже находящиеся в шаре"

"Добавить скачанные фалы в шару"

"Брандмауэр с ручным перенаправлением портов"

"Не учитывать настройки хабов"

Запрещены галочки:

"Прямое соединение"

Вернуться выше

Подняться вверх

© Предоставляется PPA


autoban

Система AutoBAN

блокирует пользователей, не подходящих по критериям, заядлых личеров (тех, кто только скачивает, не давай ничего взамен)

"Автобан" по умолчанию отключен


строка ввода сообщения

Окно для ввода сообщений в чат можно делать в два раза выше

(перевод строки выполняется нажатием Ctrl+Enter)


colorfile

2


режимы DC

Общая информация

По большому счету, существует всего два основных режима соединения у DC. Один из них называется Активным (Active), а другой - соответственно, Пассивным (Passive). Есть и другие режимы, например, для работы через Socks5-прокси, но они достаточно экзотичны, и потому нам на сегодня неинтересны.

Почему они существуют?

Прежде всего, разделение режимов придумано для того, чтобы позволить работать в сети DC как можно большему количеству людей.

Люди подключаются к сети разными способами, которые часто налагают ограничения на возможности их работы. Сеть DC, как следует из ее названия (а DC расшифровывается как Direct Connect, "соединение напрямую"), строится на возможности установления прямых соединений между пользователями. Эти прямые соединения составляют самую суть работы в сети DC: с их помощью осуществляется как файловый обмен между пользователями, так и поиск информации в сети. Если между какими то двумя пользователями не удастся установить такого вот прямого соединения - они друг у друга ничего не смогут скачать и даже найти.

Если пользователь подключен к сети непосредственно (например, звонит провайдеру обычным модемом или имеет индивидуальное ADSL-подключение) - он обычно в состоянии как инициировать прямые соединения с другими пользователями сети (совершать исходящие соединения), так и принимать запросы на такие соединения от прочих пользователей (принимать входящие соединения). Такой пользователь может уведомить об этом хаб сети DC, подключившись к нему в активном режиме.

Однако, если пользователь работает с сетью DC через посредника (например, подключен через районную или домовую локальную сеть) - обычно он лишен возможности принимать входящие соединения, а может только совершать исходящие. Именно для такого случая и придуман пассивный режим работы пользователя, позволяющий ему хоть как-то работать с сетью DC даже с такого "урезанного в возможностях" подключения.

У внимательного читателя может возникнуть вопрос, как же так получается, что к пассивному пользователю вообще кто то подключается, если принимать соединения он не может? Вопрос хороший, а ответ на него еще лучше - никак не получается ;) В этом случае активный пользователь, желающий подключиться к пассивному, направляет ему через хаб, к которому подключены они оба, "просьбу" для пассива установить с ним соединение. Пассивный пользователь эту просьбу выполняет, и прямое соединение, таким образом, устанавливается по его инициативе как исходящее.

Чем они отличаются?

Пользователь активного режима - полноценный участник сети DC. Поскольку он "умеет" как устанавливать новые соединения с другими пользователями, так и принимать их от других, он ничем не ограничен в своих возможностях работы с сетью и поиска информации в ней.

Пользователь пассивного режима - не в состоянии принимать входящие соединения от других. Он может только устанавливать соединения по своей инициативе. Оттого он не в состоянии работать с другими пассивными пользователями сети DC (и в самом деле - если оба пользователя не умеют принимать соединения, то как они свяжутся друг с другом?). Кроме того, поскольку поиск тоже осуществляется через прямое соединение между пользователями, "пассив" вынужден пользоваться для поиска услугами хаба сети, что ограничивает количество возвращаемых результатов.

Говоря короче, нормальным режимом работы пользователя в сети DC является активный. Пассивный режим следует воспринимать как вынужденную меру, применяемую лишь в случаях непреодолимых проблем (как технического, так и административного характера) с активным подключением пользователя к сети DC.

 | Активный режим | Пассивный режим
Поисковые запросы | Напрямую к/от других пользователей | Направляются хабом
Результаты поиска | Максимум 10 от каждого пользователя | Максимум 10 от каждого пользователя
Ограничения соединения | нет | Пассивные пользователи не могут соеденятся с другими пасиивными
Требуемые настройки | Настройки роутера/бранмауэра если используется | нет

Настройка активного режима

Для того, чтобы можно было работать в активном режиме без проблем, требуется настроить свое подключение к провайдеру таким образом, чтобы ничто не мешало программе DC++ принимать входящие соединения от других пользователей. Если это не сделано или сделано неправильно, то такой пользователь не сможет полноценно работать в сети даже несмотря на то, что он зарегистрирован в ней как активный.

При работе напрямую

Если Вы подключаетесь к провайдеру напрямую, то чаще всего - да практически всегда! - причиной блокировки приема входящих соединений является всего лишь неверно или не до конца настроенный системный firewall. Поэтому прежде всего необходимо убедиться, что для программы-клиента DC++ в нем разрешены не только исходящие, но и входящие соединения. Обычно для этого достаточно занести эту программу в список доверенных приложений в файрволле. Если же ваш файрволл не имеет такого списка, то потребуется добавить соответствующие правила ("разрешить для этого приложения все входящие и исходящие соединения по протоколам TCP и UDP") вручную.

При работе через чужую сеть

Другое дело, если Вы подключаетесь к провайдеру через домовую локальную сеть, и оттого вынуждены работать в пассиве. В этой ситуации тоже можно что-то предпринять, чтобы все же запустить активный режим. Но для этого будет уже недостаточно только Ваших усилий.

Для того, чтобы вам можно было работать в активном режиме, администратор вашей локальной сети (или человек, отвечающий за работу ее шлюза в сеть провайдера, который часто называют в обиходе роутер или сервер) должен будет произвести его дополнительную настройку. Более подробно о том, как именно настраивается работа активного режима через шлюз чужой сети, можно почитать в соответствующей статье. Если вы сами являетесь администратором локальной сети (например, вы подключаетесь через PPPoE и настроили ваше соединение в роутере), то можете прочитать соответсвующее руководство по настройке NAT (для роутера D-Link DSL-500T).

Администратор, однако, может отказаться это проделать по различным причинам, от банального нежелания и лени до каких-либо технических препятствий. В таком случае вам лишь остается продолжать пользоваться пассивным режимом.

Проблемы и решения

Как же определить, что Вы пытаетесь работать в активном режиме за ненастроенным файрволлом или шлюзом? Если Вы работаете в активном режиме, и замечаете, что другие пользователи (особенно пассивы) ничего не могут с Вас скачать, жалуясь на ошибки Connection timeout - это один из признаков. Может быть и наоборот - с Вас качают нормально, а вот Вы не можете ни к кому подключиться с такой же ошибкой. Вы можете также вдруг обнаружить, что не работает поиск файлов.

Многие пользователи сами не подозревают, что у них есть и включен файрволл. Они могут решить, что раз никогда ничего подобного не устанавливали, то его у них нет. Это не всегда так. Например, в операционных системах Windows XP и Windows Server 2003 файрволл не просто есть, но и по умолчанию включен. Убедиться в этом можно, зайдя в список сетевых соединений и проверив наличие на их значках маленького желтого замка. Если он есть - системный файрволл включен, и ему тоже потребуется настройка.

Обычно системный файрволл, хотя его и достаточно для базовой защиты компьютера от внешних атак из сети, достаточно просто устроен и настраивается не очень гибко. Специализированные программы от третьих фирм, такие как Agnitum Outpost или Kerio Personal Firewall, обычно гораздо удобнее в настройке, надежнее и обладают множеством дополнительных возможностей. Однако, с другой стороны, они обычно и сложнее, а зачастую - и стоят денег.

Решать, ставить или не ставить альтернативный продукт в качестве файрволла, вам, но я бы посоветовал это все же сделать. Главное - в этом случае не забудьте отключить системный файрволл (снять галочки "Защитить это подключение..." в свойствах сетевых соединений). Когда на компьютере работают одновременно два файрволла - ни к чему хорошему это обычно не приводит. Глюки могут быть самыми фееричными.

Как настраивать встроенный файрволл Windows?

* Активный режим DC за встроенным файрволлом

* Активный режим DC за встроенным файрволлом SP2

Как настраивать файрволл другого производителя?

* Активный режим DC за Kerio Personal Firewall 2.x

* Активный режим DC за Agnitum Outpost Firewall Pro

* Активный режим DC за шлюзом

Руководства по настройке других файрволлов можно поискать в Интернете на сайтах их производителей.

Проблемы остались?

Даже после того, как Вы правильно произвели всю настройку системы со своей стороны, и, наконец, вышли в сеть DC в активном режиме, вы можете столкнуться с ситуацией, когда перекачка не срабатывает. Бывает и такое, ведь нормальная работа двух пользователей активного режима между собой зависит от настроек их обоих. Вполне возможно, что проблема уже не у вас, а в том, что пользователь, с которого Вы пробуете качать (или который безуспешно пробует качать с Вас), не настроил у себя активный режим как полагается. В таком случае вы ничего не сможете поделать, кроме как сообщить ему о необходимости проверить его настройки.

Если же у Вас ничего так и не выходит - не отчаивайтесь. Прежде всего - внимательно перечитайте этот текст с самого начала. Убедитесь, что Вы поняли и выполнили предложенные в нем рекомендации. Если и это не разрешит ситуацию - обращайтесь за помощью непосредственно к администраторам хаба сети DC (это те ребята, у которых в списке вместо значка нарисованы ключики).


infouser

9


ipsearch

К настройкам сети добавлена возможность задавать адрес с указанием скрипта определения IP

Cкрипт getip.php

<?

# Скрипт определения IP адреса внутреннего пользователя сети Domolink

# Форма запроса:

# http://ppa.leschat.net/getip.php

# Автор: SkazochNik (6.01.07) skazochnik97@lipetsk.ru

ignore_user_abort(1);

$host=$_SERVER['REMOTE_ADDR'];

print "<html><head><title>Current IP Check</title></head><body>Current IP Address: $host</body></html>

";

?>


iptrust

ip, не входящие в диапозон 195.34.224.1-195.34.255.254, будут блокироваться!


limitstream

3


linux_wine

Получилось детектировать работу под эмулятором wine (спасибо mt2006)

Программа с r223 будет автоматически определять факт запуска под линуксом

функция имеет вид

static bool running_under_wine()

{

HMODULE module = GetModuleHandleA("ntdll.dll");

if (!module)

return 0;

return (GetProcAddress(module, "wine_server_call") != NULL);

}

+ можно принудительно запустить прогу с ключем /wine

if(_tcsstr(lpstrCmdLine, _T("/wine"))!=NULL)

g_RunningUnderWine = true;

в обоих случаях отключается прогрессы и минимизация в трей.


maskirovka

Возможность подменить тэг для избранного хаба

(функция предназначена для исключения бана на хабах за использования FlylinkDC++)


новый вид поиска

static const char* typeCDImage[] =

{ ".iso", ".nrg", ".mdf", ".mds", ".vcd", ".bwt",".ccd",".cdi",".pdi",".cue" };

Примечание: Данная функция работает только между клиентами приложения FlylinkDC++


savelocation

1


Окна Перевожу, не успел еще

Окна

Перевожу, не успел еще
Top

"Открывать при запуске"

Временно выключить режим "автобана" - При запуске автоматически выключает "автобан"

Если отметить что-то галочкой, то эти окна будут открываться при запуске программы:

Избранные хабы

Друзья

Очередь Скачивания

Завершенные скачивания

Очередь отдачи

Завершенные отдачи

Поиск-шпион

Сетевая статистика

Блокнот

CDM отладчик

"Настройки окон"

Открывать Личные сообщения в отдельном окне

Если выключить эту опцию, ЛС будут приходить в главном чате, ввиде статусного сообщения. Если вы не часто следите за главным чатом, вы можете пропустить сообщение. You may not care much for private messages from other users. Ignoring them however, not only lessens the (user-friendly) Direct Connect experience, but is not always wise because failing to reply to a message from an Operator can get you kicked or, in the worst case, permanently banned from that hub.

Открывать личные сообщения от ботов в отдельном окне

Активируйте, если хотите получать ЛС от ботов в отдельном окне. Если не активно, . This option only matters if you're not ignoring private messages from offline users (previous option).

Open New File List Windows in the Background

Keep this disabled if you want newly downloaded file lists to pop up in front of other windows. It can be very annoying to have a new window pop up when you're typing something.

Open New Private Message Windows in the Background

Keep this disabled if you want new private messages file lists to pop up in front of other windows.

Open new window when using /join

When using /join <ip>, a new window with the hub will open.

Ignore Private Messages From Offline Users

Enable this if you wish to ignore private messages from users that are not online on the hub. These messages originate from hub bots and generally contain useful information, like hub specific rules or warnings.

Toggle window when selecting an active tab

With this option enabled, clicking on an active tab will mimic the behavior of Windows 98+ and send the currently active window to the background. The most recently accessed window will become the new active window.

Confirm dialog options

Confirm Application Exit

Enabling this option will cause DC++ to prompt you before exiting.

Confirm favorite hub removal

Enabling this option will cause DC++ to prompt before you remove a favorite hub.

Confirm item removal in download queue

Enabling this option will cause DC++ to prompt before you remove a file (or files) from the download queue.


whois

Добавлен вывод логотипа и имени района.

Настройка выполняется вот в этих файлах.

C:\Program Files\Domolink\Settings\CustomLocations.bmp

C:\Program Files\Domolink\Settings\CustomLocations.ini